Required attachments should not be turned to inline

RESOLVED DUPLICATE of bug 65794

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 65794
11 years ago
11 years ago

People

(Reporter: Jean-Francois Dockes, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8.0.2) Gecko/20060423 Firefox/1.5.0.2
Build Identifier: version 1.5.0.5 (20060905)

Thunderbird will change a request to attach a .txt file into an inline part (content-disposition: inline). I believe this to be a bad idea for several reasons:
- This interprets and changes the user request.
- The text file may have special formatting (ie checksummed licence file), where blank space may be significant. The recipient will have trouble recovering the exact data if his mua doesn't have an easily accessible option for saving inline parts to files.
- The character set of the file is unknown and this may result in garbage display for the recipient.
Agreed,none of these problems exist if the recipient's mua is thunderbird. But there are other mail tools that don't behave so well given an inline part with a file name.

Reproducible: Always

Steps to Reproduce:
1. Attach a text (.txt) file to any message

Actual Results:  
Content-Type: text/plain;
 name*=ISO-8859-1''%E9nerv%E9.txt
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline;
 filename*=ISO-8859-1''%E9nerv%E9.txt

Contenu de l'=E9nerv=E9

Expected Results:  
Content-Transfer-Encoding: quoted-printable
Content-Disposition: attachment;
 filename*=ISO-8859-1''%E9nerv%E9.txt

Contenu de l'=E9nerv=E9

Comment 1

11 years ago
Yeah, its very annoying.

*** This bug has been marked as a duplicate of 65794 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.