bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Wrong page rendering (livejournal.com)

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: didaio, Unassigned)

Tracking

1.8 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

30.70 KB, image/gif
Details
48.62 KB, application/x-zip-compressed
Details
353 bytes, text/html
Details
230 bytes, text/html
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060902 BonEcho/2.0b2

Page is rendering incorectly in FF2 beta2. Look at attachment.

Reproducible: Always
(Reporter)

Comment 1

12 years ago
Created attachment 236878 [details]
Screenshot

Comment 2

12 years ago
Which part are you complaining about? The fact that the tabs at the top don't have spacing above them anymore, or the fact that the div with the foreign text in it isn't displayed at all?
(Reporter)

Comment 3

12 years ago
Adam, I told about white spaces after forms and tabs at the top don't
have spacing above them anymore.
Div with the foreign text isn't bug.
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.8 Branch

Comment 4

12 years ago
OK. So I am not going to sign up for livejournal.com just to reproduce this bug. Reporter, can you please File > Save as Webpage complete, make sure you can reproduce locally, zip it up and then attach it to the bug? Thanks.
(Reporter)

Comment 5

12 years ago
Created attachment 238179 [details]
Full page with problem

Comment 6

12 years ago
The bug about the margins under the forms is bug 205732. There was a bug where we didn't render them properly; now we do.

As for the issue with the spacing above the navigational tabs, I can't figure that out since the page you attached didn't have the "Your settings have been saved" div in it.
(Reporter)

Comment 7

12 years ago
Created attachment 238236 [details]
2nd version of full html
Attachment #238179 - Attachment is obsolete: true

Comment 8

12 years ago
I can't reproduce the issue with the spacing above the tabs on my system (Linux). Maybe it's Windows-only...
Created attachment 238270 [details]
testcase, standards mode
Created attachment 238274 [details]
testcase, quirks mode

So I get it minimised to this.
In quirks mode, you get the 1em margin. I think this has changed when the margin-bottom:1em; rule of form has moved from forms.css to quirk.css

(In reply to comment #8)
> I can't reproduce the issue with the spacing above the tabs on my system
> (Linux). Maybe it's Windows-only...

Do you see difference between the quirks and standards testcase on trunk?

Comment 11

12 years ago
So is this INVALID, then?
Yes, something that changed with bug 41806.
(I got the impression you saw something else)

Comment 13

12 years ago
Well, there were two issues here:

1. There was more space below the <selects> in the <fieldset>. That was just because the page is using a margin that we're now showing that we didn't used to show.

2. The second issue is the one that you (Martijn) minimized involving the rendering of <form>s in quirks mode. I do, in fact, see this behavior in current trunk builds.

That said, this is INVALID. The site shouldn't be using using that margin on the <select> if they don't want it there, and they should use a DOCTYPE if they want to be rendered in standards mode. ->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.