Context menu separators disappear when hovered over

VERIFIED FIXED

Status

()

Core
XUL
VERIFIED FIXED
12 years ago
10 years ago

People

(Reporter: Adam Guthrie, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060906 Minefield/3.0a1

Steps to reproduce:
1. Open the File menu.
2. Move your mouse to the button of the menu and back to the top a few times.

Results:
Menu separators disappear.

Expected results:
Menu separators are still instact.

This regressed between 2006-09-06-04 and 2006-09-07-04, so my bets are on bug 348304 / bug 351318.

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-09-06+03&maxdate=2006-09-07+05&cvsroot=%2Fcvsroot

Updated

12 years ago
Depends on: 70798

Updated

12 years ago
Blocks: 70798
No longer depends on: 70798
(Assignee)

Comment 1

12 years ago
Created attachment 237200 [details] [diff] [review]
Proposed patch

Bah, who are these theme authors who assume nsITheme support?
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #237200 - Flags: superreview?(roc)
Attachment #237200 - Flags: review?(roc)
(Reporter)

Comment 2

12 years ago
*** Bug 351796 has been marked as a duplicate of this bug. ***

Comment 3

12 years ago
I tried the patch(attachment 237200 [details] [diff] [review]).
It looks good.
Please review it.
(Reporter)

Updated

12 years ago
Blocks: 351773
(Assignee)

Comment 4

12 years ago
Created attachment 237518 [details] [diff] [review]
Alternative patch
(Reporter)

Comment 5

12 years ago
If we can't get this reviewed and landed today, I think we need to backout bug 70798 seeing as how it's basically a smoketest blocker on Linux (ref. bug 351773).

See also http://talkback-public.mozilla.org/reports/firefox/FFTrunk/FFTrunk-topcrashers.html which shows almost 60 crashes in libc.so.6 since this patch landed. (It's crashing in cairo-related code that deals with drawing the menus.)
Comment on attachment 237200 [details] [diff] [review]
Proposed patch

This is the right thing.
Attachment #237200 - Flags: superreview?(roc)
Attachment #237200 - Flags: superreview+
Attachment #237200 - Flags: review?(roc)
Attachment #237200 - Flags: review+
(Assignee)

Comment 7

12 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

12 years ago
Verified FIXED using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060911 Minefield/3.0a1.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: xptoolkit.menus → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.