Thunderbird crash on sending a return receipt [@ nsMsgMdnGenerator::CreateSecondPart]

RESOLVED FIXED

Status

MailNews Core
Backend
--
critical
RESOLVED FIXED
11 years ago
6 years ago

People

(Reporter: Piviul, Assigned: Bienvenu)

Tracking

({crash, fixed1.8.1.8})

1.8 Branch
crash, fixed1.8.1.8

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; it; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla Thunderbird 1.5.05 (20060719)

When I receive a message from a specific user that use lotus notes with an automatic return receipt, when I send the return receipt TB crashes.

Reproducible: Always

Steps to Reproduce:
This is one of the messages I received that crashes TB.

From - Thu Sep 07 15:07:11 2006
X-Account-Key: account2
X-UIDL: 1157634406.32443_2.servercsa
X-Mozilla-Status: 0000
X-Mozilla-Status2: 00000000
Return-Path: <Elisabetta.Castagnoli@gruppohera.it>
Delivered-To: ifagiolino@servercsa.csaricerche.com
Received: (qmail 32439 invoked by alias); 7 Sep 2006 13:06:46 -0000
Delivered-To: alias-localdelivery-ifagiolino@csaricerche.com
Received: (qmail 32436 invoked by uid 453); 7 Sep 2006 13:06:46 -0000
X-Spam-Status: No, hits=4.9 required=5.0
	tests=BAYES_00,BLANK_LINES_70_80,INVALID_DATE,NO_REAL_NAME,RAZOR2_CF_RANGE_51_100,RAZOR2_CF_RANGE_E4_51_100,RAZOR2_CHECK
X-Spam-Check-By: csaricerche.com
Received: from smtp1.meta.mo.it (HELO smtprelay2.meta.mo.it) (213.209.221.142)
    by csaricerche.com (qpsmtpd/0.31.1) with ESMTP; Thu, 07 Sep 2006 15:06:45 +0200
Importance: Normal
X-Priority: 3 (Normal)
Subject: vuoto
Sensitivity: 
To: ifagiolino@csaricerche.com
Cc: 
From: Elisabetta.Castagnoli@gruppohera.it
Date: 07-Sep-2006 15:06:39 CEDT
Message-ID: 
Disposition-Notification-To: Elisabetta.Castagnoli@gruppohera.it
X-MIMETrack: Serialize by Router on DOMRELAY02/SVR/META/IT(Release 6.5.5|November 30, 2005) at
 07/09/2006 15:04:26
MIME-Version: 1.0
Content-type: text/plain; charset=US-ASCII


--

Comment 1

11 years ago
Please get a Talkback ID for the crash. http://kb.mozillazine.org/Talkback
Severity: minor → critical
Keywords: crash
(Reporter)

Comment 2

11 years ago
I've tried more an more times to send a talkback id but I receive ever the same error:  "The Agent is unable to connect to the server. Please check your Proxy Server settings or try again later." 
There is another way to send a talkback Id to the developers?

Piviul

Comment 3

10 years ago
I have also been experiencing Thunderbird 2.0 crashes upon clicking 'OK' to send a return receipt.  I have seen it happen consistently on a Win 98, Win XP SP2, and Vista Business machine.  I have only seen it happen in response to a request from an Outlook 2003 client.  I have tested returning receipt requests from Outlook 2000, Outlook 2007, and a webmail client without problem.  All these Outlook clients are configured with an IMAP connection using Outlook Connector (for mdaemon mail server).

This same problem is described in Bug 384293 with some different details.

The following is a message that resulted in a crash when sending the read receipt:

Return-path: <edavis@farmersfurniture.com>
Authentication-Results: farmersfurniture.com
	smtp.mail=edavis@farmersfurniture.com; auth=pass
Received: from edavis-xp.farmers.intranet by farmersfurniture.com
	(MDaemon PRO v9.5.6)
	with ESMTP id md50003843429.msg
	for <SCrombie@farmersfurniture.com>; Tue, 10 Jul 2007 15:03:55 -0400
Date: Tue, 10 Jul 2007 15:03:00 -0400
From: Eric Davis <edavis@farmersfurniture.com>
Subject: Crash email
To: "'Steven Crombie \\(E-mail\\)'" <SCrombie@farmersfurniture.com>
X-Priority: 3
Organization: Farmers Furniture
Disposition-Notification-To: edavis@farmersfurniture.com
X-Mailer: Outlook Connector for MDaemon 2.1.3
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: quoted-printable
X-Authenticated-Sender: edavis@farmersfurniture.com
X-Spam-Processed: farmersfurniture.com, Tue, 10 Jul 2007 15:03:55 -0400
	(not processed: sender in recipient's private address book)
X-MDRcpt-To: SCrombie@farmersfurniture.com
X-Rcpt-To: SCrombie@farmersfurniture.com
X-Return-Path: edavis@farmersfurniture.com
X-Envelope-From: edavis@farmersfurniture.com
X-MDaemon-Deliver-To: SCrombie@farmersfurniture.com
X-MDAV-Processed: farmersfurniture.com, Tue, 10 Jul 2007 15:03:56 -0400

Testing thunderbird




Comment 4

10 years ago
I have now received an email requesting a read receipt from an Outlook 2003 client using a POP3 connection.  The read receipt was returned without any errors or crashing.

My problem seems to exist only when the sender is using Outlook 2003 with an IMAP connection using Outlook Connector for Mdaemon.

Updated

10 years ago
Duplicate of this bug: 384293

Comment 6

10 years ago
Steven, or anyone who's experiencing this, can you get a Talkback ID for the crash? http://kb.mozillazine.org/Talkback
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: stackwanted
Version: unspecified → 2.0

Comment 7

10 years ago
Talkback ID is TB34002646X.
(Assignee)

Comment 8

10 years ago
Ah, thx for the stack. My guess is that Outlook is not generating a message id in this scenario. Can you check the mdn request message and see if Outlook put a Message-Id: header in it?

nsMsgMdnGenerator::CreateSecondPart  [mozilla/mailnews/extensions/mdn/src/nsMsgMdnGenerator.cpp, line 742]
nsMsgMdnGenerator::CreateMdnMsg  [mozilla/mailnews/extensions/mdn/src/nsMsgMdnGenerator.cpp, line 432]
nsMsgMdnGenerator::InitAndProcess  [mozilla/mailnews/extensions/mdn/src/nsMsgMdnGenerator.cpp, line 974]
nsMsgMdnGenerator::Process  [mozilla/mailnews/extensions/mdn/src/nsMsgMdnGenerator.cpp, line 1000]
XPTC_InvokeByIndex  [mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp, line 102]
XPCWrappedNative::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2169]
XPC_WN_CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1455]
js_Invoke  [mozilla/js/src/jsinterp.c, line 1375]
js_Interpret  [mozilla/js/src/jsinterp.c, line 3944]
js_Invoke  [mozilla/js/src/jsinterp.c, line 1394]
nsXPCWrappedJSClass::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1415]
nsXPCWrappedJS::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 468]
SharedStub  [mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp, line 147]
nsMimeHtmlDisplayEmitter::EndBody  [mozilla/mailnews/mime/emitters/src/nsMimeHtmlEmitter.cpp, line 586]
mimeEmitterEndBody  [mozilla/mailnews/mime/src/mimemoz2.cpp, line 1907]
mime_display_stream_complete  [mozilla/mailnews/mime/src/mimemoz2.cpp, line 963]
nsStreamConverter::OnStopRequest  [mozilla/mailnews/mime/src/nsStreamConverter.cpp, line 1022]
nsDocumentOpenInfo::OnStopRequest  [mozilla/uriloader/base/nsURILoader.cpp, line 390]
nsStreamListenerTee::OnStopRequest  [mozilla/netwerk/base/src/nsStreamListenerTee.cpp, line 65]
nsStreamListenerEvent0::HandlePLEvent  [mozilla/netwerk/base/src/nsAsyncStreamListener.cpp, line 122]
Assignee: mscott → bienvenu

Updated

10 years ago
Assignee: bienvenu → nobody
Component: Message Compose Window → MailNews: Backend
Keywords: stackwanted
Product: Thunderbird → Core
QA Contact: message-compose → backend
Summary: Thunderbird crash on sending a return receipt → Thunderbird crash on sending a return receipt [@ nsMsgMdnGenerator::CreateSecondPart]
Version: 2.0 → 1.8 Branch

Comment 9

10 years ago
It appears you are correct that there is no Message-ID field.  I checked a message from Outlook 2007 client also on IMAP via Outlook Connector and the Message-ID field is present.  I have successfully returned read receipts to that client.  

Here is the message source for the problem email minus the winmail.dat attachment.

Return-path: <cilcarter@farmersfurniture.com>
Authentication-Results: farmersfurniture.com
	smtp.mail=cilcarter@farmersfurniture.com; auth=pass
Received: from [10.200.90.123] by farmersfurniture.com
	(MDaemon PRO v9.5.6)
	with ESMTP id md50003860137.msg
	for <SCrombie@farmersfurniture.com>; Fri, 13 Jul 2007 11:06:43 -0400
Date: Fri, 13 Jul 2007 11:09:00 -0400
From: Cecilia Carter <cilcarter@farmersfurniture.com>
Subject: Test
To: 
    "Steven Crombie (SCrombie@farmersfurniture.com)" <SCrombie@farmersfurniture.com>
X-Priority: 3
Organization: Farmers Furniture
X-MS-TNEF-Correlator: ERTF-0wn7df9Q-VxuJQl9vKFxJLqgFgE87jgnuZ1kSLG
Disposition-Notification-To: cilcarter@farmersfurniture.com
X-Mailer: Outlook Connector for MDaemon 2.1.3
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary=9154109-18467-1184339392-3544
X-Authenticated-Sender: cilcarter@farmersfurniture.com
X-Spam-Processed: farmersfurniture.com, Fri, 13 Jul 2007 11:06:43 -0400
	(not processed: message from valid local sender)
X-MDRcpt-To: SCrombie@farmersfurniture.com
X-Rcpt-To: SCrombie@farmersfurniture.com
X-Return-Path: cilcarter@farmersfurniture.com
X-Envelope-From: cilcarter@farmersfurniture.com
X-MDaemon-Deliver-To: SCrombie@farmersfurniture.com
X-MDAV-Processed: farmersfurniture.com, Fri, 13 Jul 2007 11:06:43 -0400

--9154109-18467-1184339392-3544
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: quoted-printable

This message has a read receipt.




(Assignee)

Comment 10

10 years ago
Yeah, Outlook is evil that way, and doesn't generated message-id's in some situations. I'll try to come up with a fix; thx for the diagnosis. It might be helpful at some point for me to be able to receive an mdn request message like this, once I have a fix to test.
Assignee: nobody → bienvenu

Comment 11

10 years ago
I would be glad to have some messages sent for testing.  Thanks for your help.
(Assignee)

Comment 12

10 years ago
So handling missing message-id's was fixed back in 2004 (the year, not the TB version), so yes, an mdn request like this would be very helpful, if you could send them to bienvenu@nventure.com. Thx!
(Assignee)

Comment 13

10 years ago
see bug 224738
(Assignee)

Comment 14

10 years ago
Created attachment 272978 [details] [diff] [review]
proposed fix

Check if the message-id is empty - this code is in two places, which is what was confusing me earlier.

I don't think this bug happens on the trunk since we're not using XPIDLCString anymore, but I'll try to verify.
Attachment #272978 - Flags: superreview?(mscott)
Attachment #272978 - Flags: approval1.8.1.6?
(Assignee)

Comment 15

10 years ago
yes, the trunk is not affected by this problem, anymore.
Status: NEW → ASSIGNED
OS: Windows 2000 → All
Hardware: PC → All

Updated

10 years ago
Attachment #272978 - Flags: superreview?(mscott) → superreview+

Comment 16

10 years ago
Comment on attachment 272978 [details] [diff] [review]
proposed fix

Nit: Indentation.
(Assignee)

Comment 17

10 years ago
it's a -uw patch - I believe the indentation in my tree is fine.

Comment 18

10 years ago
What's the latest status on this bug?  Will the proposed patch be included in an update soon?
(Assignee)

Comment 19

10 years ago
I've requested approval for the next security and stability release, but have not received it yet. We've been doing some 2.0.0.x security drills, which haven't allowed time to get the stability fixes in.
Comment on attachment 272978 [details] [diff] [review]
proposed fix

approved for 1.8.1.7, a=dveditz for release-drivers
Attachment #272978 - Flags: approval1.8.1.7? → approval1.8.1.7+
(Assignee)

Comment 21

10 years ago
fixed for 1.8.1.7
Keywords: fixed1.8.1.7
(Assignee)

Comment 22

10 years ago
marking fixed, since this isn't an issue on the trunk, and it's fixed on the branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Reporter: Can you download the latest nightly or the 2.0.0.8 candidate build when it is available and help us verify that this is fixed? You can find the builds here: ftp://ftp.mozilla.org/pub/thunderbird/nightly.

Comment 24

10 years ago
Sorry .. not sure if this is the right place.  Running vanilla TB version 2.0.0.6 as per the automatic update.

Using an (oracle) IMAP server.  When trying to OK a return receipt, TB just hangs
and has to be killed and restarted.  Tried re-installing  2.0.0.4.  I changed themes a couple of time and it "seemed" to work..

Updated to 2.0.0.6 via the automatic update and again starting hanging again.
Fiddled around with themes again with no result ... I am not sure if that is relevant.

It seems that from this thread this was flagged as a bug and an update to 2.0.0.8
may fix the problem. Assuming this is the same problem.

If an upgrade to 2.0.0.8 fixes this problem, can I please get an unambiguous link, as I struggle with one above.

TIA
Peter
Product: Core → MailNews Core
Crash Signature: [@ nsMsgMdnGenerator::CreateSecondPart]
You need to log in before you can comment on or make changes to this bug.