Last Comment Bug 352049 - Kill the font download dialog
: Kill the font download dialog
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: x86 Windows XP
: P2 normal (vote)
: mozilla1.9alpha1
Assigned To: Christian :Biesinger (don't email me, ping me on IRC)
: Yuying Long
Mentors:
Depends on:
Blocks: 84955 86525 92596 93982 183044 286617
  Show dependency treegraph
 
Reported: 2006-09-10 10:38 PDT by Christian :Biesinger (don't email me, ping me on IRC)
Modified: 2006-09-11 03:56 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (63.42 KB, patch)
2006-09-10 11:00 PDT, Christian :Biesinger (don't email me, ping me on IRC)
smontagu: review+
bzbarsky: superreview+
Details | Diff | Review
as diff -w (and without all the file removals) (19.25 KB, text/plain)
2006-09-10 11:05 PDT, Christian :Biesinger (don't email me, ping me on IRC)
no flags Details

Description Christian :Biesinger (don't email me, ping me on IRC) 2006-09-10 10:38:48 PDT
Since the dialog is annoying, not very useful on NT-based Windows variants (only asks users to go to the control panel), and doesn't with thebes (HaveFontFor always returns true, and the code probably never calls the font package service anyway), it should be killed.
Comment 1 Christian :Biesinger (don't email me, ping me on IRC) 2006-09-10 11:00:42 PDT
Created attachment 237624 [details] [diff] [review]
patch

The seemingly large change in nsWindow.cpp is mostly reindentation
Comment 2 Christian :Biesinger (don't email me, ping me on IRC) 2006-09-10 11:05:21 PDT
Created attachment 237626 [details]
as diff -w (and without all the file removals)
Comment 3 Simon Montagu :smontagu 2006-09-10 11:45:48 PDT
Comment on attachment 237624 [details] [diff] [review]
patch

Thank you for doing this!
Comment 4 Christian :Biesinger (don't email me, ping me on IRC) 2006-09-10 12:16:02 PDT
fixed on trunk!

Note You need to log in before you can comment on or make changes to this bug.