Closed Bug 352188 Opened 14 years ago Closed 14 years ago

Month and Multiweek view: pressing del-key does not delete event

Categories

(Calendar :: Calendar Views, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Sunbird 0.3

People

(Reporter: sebo.moz, Assigned: michael.buettner)

Details

(Keywords: regression)

Attachments

(1 file)

Pressing the delete key after selecting an event in the main view does not delete event. This is happening in Lightning (Month view) and Sunbird (Month view/Multiweek view). It works in Unifinder and in Day view/week view.

Steps to reproduce:
1. create event
2. highlight event in month view
3. press del-key

Result: nothing happens.
In combination with bug 352071 it is not easy to delete events, at least in lighning/Month view it is not possible at all.
Flags: blocking0.3?
This regression was caused by the selection checkin, I believe.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking0.3? → blocking0.3+
OS: Windows XP → All
Hardware: PC → All
Doesn't this _dupe_ 352071?
(In reply to comment #3)
> Doesn't this _dupe_ 352071?
no, unfortunately not. 352071 is lightning specific (in messenger-overlay-sidebar.js), but this bug applies to sunbird as well as lightning. seems to have something to do with the month-view.

Attached patch patch v1Splinter Review
again a regression from the selection check-in...
Assignee: nobody → michael.buettner
Status: NEW → ASSIGNED
Attachment #237973 - Flags: second-review?(dmose)
Attachment #237973 - Flags: first-review?(thomas.benisch)
Comment on attachment 237973 [details] [diff] [review]
patch v1

no comment
r1=tbe
Attachment #237973 - Flags: first-review?(thomas.benisch) → first-review+
Comment on attachment 237973 [details] [diff] [review]
patch v1

r2=dmose; thanks for the fix!
Attachment #237973 - Flags: second-review?(dmose) → second-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060917 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
Whiteboard: [litmus testcase wanted]
Litmus testcase 2692 created
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.