Multiple entries for same event in Agenda (after calendar reload)

VERIFIED FIXED in Lightning 0.5

Status

VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: robert.cox, Unassigned)

Tracking

unspecified
Lightning 0.5

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Lightning 0.1+ (2006091106)

I have muliple entries for the same event in agenda.

I believe these occur for each time I have refreshed the remote calendar, by clicking on refresh.

Reproducible: Always

Steps to Reproduce:
1. refresh remote calendar
2. look at agenda and see another entry the same as before
3.

Actual Results:  
(see step 2) see another identical entry in agenda.

Expected Results:  
one entry per event

The calendar is created via iCal on a Macintosh and published to a webdav server.  My PC then runs TB1.5 and lightning to access the calendar in read only mode.  This is then displayed in the calendar (only once) - just the agenda where it is multiple times.
(Reporter)

Comment 1

12 years ago
When I quit out of Thunderbird and restart it again it cleans it up.

Then I try to make it happen again and it won't do it again.  Tried creating more entries in the remote calendar and also reloading with nothing changed and can't make it do it again.
Keywords: qawanted

Comment 2

12 years ago
this is not reproducible by the reporter and WORKSFORME

Reporter, did you see this happening again?
(Reporter)

Comment 3

12 years ago
I have tested several times to try and make it do it, but no I can't reproduce it, I do have a much later nightly now.
-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
(Reporter)

Comment 5

12 years ago
Sorry guys - and then with lightning 2006092606 I am getting it again (this is not to say that this version brought it back), just that perhaps the set of circumstances that created it in the first place were not repeated.

Here is what is happening.

I move a calendar item in Apple iCal on my Mac (this calendar is created from iCal over a year ago) - this action updates a webdav server.  I then go back to lightning in TB on the PC, refresh and if something has changed if updates 

Note: I know it is refreshing a change because lightning cleans the calendar view of all the events and then puts them back again.

Then, I look in the agenda and the one I moved is in the agenda twice, once with the old time and once with the new time.  I just proved this again, and now I have 3 entries.  There is only one event in the calendar view and it is at the correct time.

Oddly, I noticed this had come back again, since I have multiple entries for all my other events in the agenda.  These are not increasing whilst I create more of the event that I change in iCal.  These duplicates in the agenda are at the same times int he agenda only like above the calendar view is correct.

Other tests I am doing - if I move the event in iCal back to an original time, then it appears like a duplicate in the the agenda.

One thought I just had, is the agenda window being refreshed often enough.  So I quit TB and restarted and there was then only one copy of each, perfectly arranged.

Hope this helps - let me know what I can send you - happy to assist.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 6

12 years ago
Tried it on my Mac on Thunderbird with lightning - same thing happens.

Comment 7

12 years ago
I have the same thing using a remote calendar (on a ftp-server). When I Reload remote calendars I have double entries in the agenda.

When I restart thunderbird the agenda is ok again.

I am using thunder birdversion 1.5.0.7 (20060909)
and a nighlty of lightning build 2006100406

on windows XP
Confirmed per Comment #7
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Mulitple Entries for same event in agenda → Mulitple entries for same event in Agenda (after calendar reload)

Comment 9

12 years ago
Bug reproduced with Google Calendar as the remote calender. Multiple entries appear in the agenda, compounding with the number of times remote calendars are reloaded.

Restarting TB+Lightning sets things right

TB 1.5.0.7 (20060909)
Lightning 2006100618
On WinXP

Comment 10

12 years ago
Possibly related (?) - receiving and accepting a .ics event notification/reminder from a subscribed Google Calendar leads to a duplicate of that event appearing in the agenda list as well. Quiting and restarting TB clears the duplicate, can be added again by accepting the invitation again.

TB 1.5.0.7 (20060909)
Lightning 0.3RC2 (2006100618)
On WinXP
*** Bug 362062 has been marked as a duplicate of this bug. ***

Comment 12

12 years ago
You just have to change the "View" to "delete" the duplicated entries. But thats just a dirty fix.
After bug 215971 was fixed Auto Reload of remote calendars is now enabled by default and triggers this bug. Therefore I think this bug should be fixed before 0.5 release.
Flags: blocking-calendar0.5?
Yes, 0.5 needs this.
Flags: blocking-calendar0.5? → blocking-calendar0.5+

Comment 15

12 years ago
Created attachment 257536 [details] [diff] [review]
check for duplicates and replace them instead off adding

This patch checks for elements with the same id before pushing them. In case of dupes it replaces rather then adding. Tested on Linux/Lightning/Branch. I hope this is not too hackyish.
Attachment #257536 - Flags: first-review?(lilmatt)
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Lightning 0.5
Comment on attachment 257536 [details] [diff] [review]
check for duplicates and replace them instead off adding

Tested on branch Lightning. Looks good.  r=lilmatt
Attachment #257536 - Flags: first-review?(lilmatt) → first-review+

Updated

12 years ago
Attachment #257536 - Flags: second-review?(mvl)
Whiteboard: [needs second-review][patch in hand]
Comment on attachment 257536 [details] [diff] [review]
check for duplicates and replace them instead off adding

clearing unneeded r2
Attachment #257536 - Flags: second-review?(mvl)
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Whiteboard: [needs second-review][patch in hand]

Updated

12 years ago
Summary: Mulitple entries for same event in Agenda (after calendar reload) → Multiple entries for same event in Agenda (after calendar reload)

Updated

12 years ago
Duplicate of this bug: 373302

Updated

11 years ago
Status: RESOLVED → VERIFIED
Flags: blocking-calendar0.5+
You need to log in before you can comment on or make changes to this bug.