Thunderbird does not correctly match file associations

RESOLVED DUPLICATE of bug 323300

Status

--
major
RESOLVED DUPLICATE of bug 323300
12 years ago
12 years ago

People

(Reporter: ty.myrick, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Thunderbird version 1.5.0.5 (20060719)

Thunderbird does not correctly match file associations

I installed Nero 7 and allowed it to set the default file associations.  All image files opened in Photosnap Viewer.  I didn't like that so I reset jpg files to Windows Picture and Fax Viewer in Control Panel > Folder Options > File Types.  When I viewed emails in TB with jpg attachments, I still saw the Photosnap Viewer icon.  When I double-clicked a jpg attachment, the Opening... dialog box showed the Photosnap Viewer icon in front of the file name and gave me the option to Open With... Nero Photosnap Image Viewer (def...

That is not what I wanted, so I downloaded Irfanview and reset all image file associations to that.  Then I went back into Folder Options and changed jpg file association back to Windows Picture and Fax Viewer.  Now jpg attachments show the Irfanview icon, the Opening... dialog shows the Irfanview icon in front of the file name, and the Open With... field gives me Nero Photosnap Image Viewer (def...  But if I actually try to open the jpg, it opens in WPFV.  You can see this in the first screen shot.  

Before opening the jpg, I set it to always open that way.  In TB, I went to Tools > Options... > Attachments > View & Edit Actions.  There jpg files have the Irfanview icon and say they will open with Nero Photosnap Image Viewer.  This can be seen in the second screenshot.  They still open in WPFV.  

How can I get it to use the WPFV icon for jpg files and give WPFV as an option for opening image files?  

Reproducible: Always

Steps to Reproduce:
1. Install Nero 7 and set file associations to the default.  
2. Open an email in TB with a jpg attachment.  
3. Double-click attachment.  
4. Choose Open With...
5. Open Drog Down box, see that Windows Picture and Fax Viewer is not available.  
6. In Folder Options set jpg file association to open in WPFV
7. Repeat steps 2-5.  
8. Install Irfanview 3.98.  
9. Set all image file associations to user Irfanview.  
10. In Folder Options change jpg file association to WPFV.  
11. In TB look at icon of jpg attachment.  
12. Double-click jpg attachment.  
13. In Opening... dialog see icon associated with file name.  
14. In Opening... dialog see Open With... default program.  
15. Click Open With...
16. Check box to save file action.  
17. Open file, see that it opens in WPFV.  
18. In TB, go to Tools > Options > Attachments > View & Edit Actions.  
19. See icon and program associated with jpg.  

Actual Results:  
JPG files show up in TB with Irfanview icon.  The default (and only) program listed for opening jpg files is Nero Photosnap Image Viewer.  JPF files open in Windows Picture and Fax Viewer. 

Expected Results:  
Opening... dialog for image files should give Windows Picture and Fax Viewer as option.  The image program associated with jpg files in XP should show as the default in the Open With... combo box.  JPG files in TB should show the icon of the image program associated with jpg files in Windows XP

The lack of Windows Picture and Fax Viewer as an option for opening image attachments in TB has been noted repeatedly in the TB forums.
(Reporter)

Comment 1

12 years ago
Created attachment 237909 [details]
Opening... dialog showing wrong jpg icon and default program
(Reporter)

Comment 2

12 years ago
Created attachment 237910 [details]
File extension actions showing wrong icon and associated program

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 323300 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.