Only platforms that have files for the latest version are shown as supported

RESOLVED WONTFIX

Status

P4
minor
RESOLVED WONTFIX
12 years ago
3 years ago

People

(Reporter: haqer, Unassigned)

Tracking

unspecified
4.x (triaged)
All
Linux

Details

(Whiteboard: [ddn], URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

This is probably a bug introduced into addons in the past few months.

Reproducible: Always

Steps to Reproduce:
1. Visit the above URL on Linux
2. Try to download the installer
3.

Actual Results:  
User has to go to history to get access to an installer, which the user may not be aware of.

Expected Results:  
User should be able to download from the main extension page.
The Linux installer is not displayed because it is version 0.2.2. The Windows version is 0.2.3. If you'd like Linux to appear, you will need to upload a Linux version for 0.2.3... the addon page will not display different versions, only the most recent.
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> The Linux installer is not displayed because it is version 0.2.2. The Windows
> version is 0.2.3. If you'd like Linux to appear, you will need to upload a
> Linux version for 0.2.3... the addon page will not display different versions,
> only the most recent.
> 
I submitted 0.2.3. But it's still a bug, IMHO. At the very list, "No Linux installer" message must be changed to something like "Linux installer version is lower than the highest version, please install it from Other versions link below".
Mmmm, no -- if you're providing an extension, you should provide it for all the platforms you support, in sync.  Providing different versions to people on different platforms is makes things that are already confusing even more so.

WONTFIX, I think.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX

Comment 4

12 years ago
Except if one is reviewed before another... which is most likely if the reviewer only has one platform to review on.
(Reporter)

Comment 5

12 years ago
Please take a 2nd look.
What i had to do is submit 0.2.2 as 0.2.3. Sometimes one needs to fix something only for Windows, or only for Mac, etc.

Plus, as mentioned, Linux installers take an average of about a month longer to be approved. Just think about what you are asking me to do:
1. submit 0.2.3 for Windows
2. have at least a month of Linux installer being inaccessible.

or 
1. submit a dummy Linux installer 0.2.3 equivalent to 0.2.2 a month before i expect to have a Windows installer for 0.2.3.
2. risk Windows installer being unavailable if Linux installer is approved sooner than Windows release is ready.

Does that sound like a quality service? No.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Comment 6

12 years ago
And there was no such problem until recently.
Looking at your review history, 3/4 of your Windows/Linux pairs were approved within a day of each other. An average of a month longer?

If we were to show different versions of an addon on the main page, the version notes would be incorrect, as would the updated date. The version number displayed everywhere (rss feed, search, addon page, etc) would be incorrect for the Linux users.

Unfortunately, updating all of the OS versions at the same time is just one of the hassles of having multiple OS files. Please feel free to utilize the "Notes to Reviewer" section to request that your two versions only be reviewed together.

Also, the code that pulls the current version has not been changed since its original check-in, so I don't think this is a problem that just started happening. http://lxr.mozilla.org/mozilla/source/webtools/addons/shared/lib/addon.class.php#204
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 8

12 years ago
(In reply to comment #7)
> Looking at your review history, 3/4 of your Windows/Linux pairs were approved
> within a day of each other. An average of a month longer?

Of the 4 multi-version releases i have made the last one was accepted for Linux by mistake by a tester on Windows. Of the 3 that were really tested, the first two were fairly close to each other, but the last one took 6 months:
2006-01-04 - 2005-08-03.


> If we were to show different versions of an addon on the main page, the version
> notes would be incorrect, as would the updated date. The version number
> displayed everywhere (rss feed, search, addon page, etc) would be incorrect for
> the Linux users.
All that needs to be done is what was done before: provide the latest version for that O.S.: right now it would be 0.2.3 for W, and 0.2.2 for L.

> Unfortunately, updating all of the OS versions at the same time is just one of
> the hassles of having multiple OS files. Please feel free to utilize the "Notes
> to Reviewer" section to request that your two versions only be reviewed
> together.
That makes it worse for me, because they won't be approved as fast, and it's a hassle for tester, because he/she is likely to have to reboot. They will probably just skip my extension, i.e. extra delay.

> Also, the code that pulls the current version has not been changed since its
> original check-in, so I don't think this is a problem that just started
> happening.
> http://lxr.mozilla.org/mozilla/source/webtools/addons/shared/lib/addon.class.php#204
> 

I don't follow the code well, cause i've never worked on addons, but there have been 4 check-ins since April in this class. I know this wasn't an issue when i had 0.2.2 W vs. 0.2.1 L last year, and 0.2.3 W vs. 0.2.2 L this spring. It is a recent bug.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
I forgot about the differential review latency, yeah.  Bleh, I shouldn't do bugmail when tired.  Confirming, but I don't think we're gonna get this fixed before Remora.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Re-summarizing for clarity.
Summary: addons says no Linux installer despite there being one → Only platforms that have files for the latest version are shown as supported
(Reporter)

Comment 11

12 years ago
It appears there have been some changes about this, but there's another weird thing i've noticed.
Please see details at:
http://pastebin.mozilla.org/1535

Updated

12 years ago
Component: Add-ons → Public Pages
QA Contact: add-ons → web-ui
Hardware: PC → All
Marking as important to Firefox 3, since the same is true for application versions. (If someone is using Firefox 2 but the latest release of the extension has a minVersion of 3.0, the user should still see the old Firefox 2 version.)
Blocks: 408146

Comment 13

11 years ago
Current workaround is to upload both platform editions of an add-on simultaneously. Will re-investigate at a later date.
Target Milestone: --- → 3.x (triaged)

Updated

11 years ago
No longer blocks: 408146
This not only holds for platforms, or application version (fx2 vs fx3), but also for applications:

I couldn't find Leak Monitor (addon 2490) when searching for it under Thunderbird extensions. Had to search in firefox, change the URL, go to old versions to see that version 0.4.1 was latest version for Thunderbird, and 0.4.2 current version for Firefox...
rdoherty:  How easy is this to do with the new install buttons?
Severity: normal → minor
Priority: -- → P4
(In reply to comment #15)
> rdoherty:  How easy is this to do with the new install buttons?

The install button code probably wouldn't change for this. The button code just blindly make install buttons for whatever files it is given when called. This would probably involve changing all our queries for valid add-on files.
I think we should wontfix this.  It's just complicating things and will lead to more edgecases and regressions.  I'd rather go the opposite direction to simplify things by implementing rules about not allowing different platforms on versions or something.  Our logic is too complex for our own good.  That's a bigger discussion though.
Whiteboard: [ddn]
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 12 years ago4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.