Autocomplete should prefer typed URLs to URLs that were merely visited

RESOLVED DUPLICATE of bug 424454

Status

()

Firefox
Address Bar
--
enhancement
RESOLVED DUPLICATE of bug 424454
12 years ago
10 years ago

People

(Reporter: plummer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

This is a feature request, not a bug.

An improvement on the Autocomplete feature would be to place more value on urls that are typed manually into the location bar versus urls that are from the browsing history.  I would suggest keeping the manually typed urls around in the Autocomplete cache for a longer period of time.  To be honest, I personally don't care to ever see my history show up in the Autocomplete.  I only care about what I type in on a repeated basis.

king regards,
Casey Plummer


Reproducible: Always

Steps to Reproduce:
1. Type in a url you use once in a while, but consistently.
2. Wait until the url expires from the Autocomplete cache.
1. Type in a url you use once in a while, but consistently.
3. Experience frustration when useless urls from the history show up in the autocomplete list.
4. Chastize the bug submitter for including sarcasm in the very serious steps to reproduce section.

Updated

12 years ago
Summary: Weighed value of a typed url versus a history url. [Search keywords: remember, autocomplete, history, type, typed, list] → Autocomplete should prefer typed URLs to URLs that were merely visited

Comment 1

12 years ago
I like this idea.
Status: UNCONFIRMED → NEW
Ever confirmed: true
the current autocomplete algorithm (on firefox 3 trunk) does this, so I'm tempted to mark it fixed (or a dup)

Updated

10 years ago
OS: Windows XP → All
Hardware: PC → All

Comment 3

10 years ago
Created attachment 294135 [details] [diff] [review]
v1

It's true that it currently does favor typed results, but giving more weight to typed in the rank will help it keep its weight when compared to other ranked results.

Comment 4

10 years ago
Should be fixed with bug 424454.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424454
You need to log in before you can comment on or make changes to this bug.