marker of current message in thread pane's list of messages is not always there after deleting message from standalone window

RESOLVED DUPLICATE of bug 172392

Status

RESOLVED DUPLICATE of bug 172392
12 years ago
11 years ago

People

(Reporter: turningoff, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

I just upgraded to the latest tbird from a version I have had around for some time.  The old version used to mark the "current" message with a blue horizontal bar in the pane that has the list of messages.

The new version tries to do that, but fails in the following instance, leaving me lost in terms of where I was working.

If I am reading a message and click delete in the individual message window, the next message comes up, but the blue bar does not mark it in the list of messages pane.  So when I close that next message, I have no idea where I am.


Reproducible: Always

Steps to Reproduce:
1. see above.
2.
3.

Actual Results:  
see above.

Expected Results:  
see above.

Comment 1

12 years ago
I have to wonder whether the "old version" actually did as you describe;
see bug 172392: this behavior existed before TB was even started as a project.
In particular, bug 172392 comment 14 gives a reasonable rationale why the selection should *not* change: when the message is deleted from the standalone window, no new message is loaded in the message pane.

This is probably a dupe of that bug, as I believe the actual navigation behavior is backend, and shared between suite and TB.
(Reporter)

Comment 2

12 years ago
Thanks for your reply.

I find myself quite confused by the discussion of a 3 pane and threads.  I do not use threads, and I am sure this is new behavior I am seeing between the latest version and whatever prehistoric version I had before, because I often delete messages using the delette button in the individual message display window and then read in sequence.  Never before have I been going what, what where am I when I close the individual message display window, because the horizontal blue bar was always there.

Perhaps if you folks are using threads a lot, you have changed something that effects us folks who do not use threads, and don't realize it?

Comment 3

11 years ago
duping per comment 1
(reporter address is dead)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Summary: marker of current message in list of messages is not always there → marker of current message in thread pane's list of messages is not always there after deleting message from standalone window
Duplicate of bug: 172392
You need to log in before you can comment on or make changes to this bug.