With caret browsing enabled, clicking a link sometimes jumps to top of the page instead

RESOLVED DUPLICATE of bug 351491

Status

()

Firefox
Keyboard Navigation
RESOLVED DUPLICATE of bug 351491
12 years ago
12 years ago

People

(Reporter: Sergey Koulik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

Hello FF team,

sometimes I observe noisy problem with accessing hyperlinks. FF goes to top of current page instead of following the hyperlink location.

Reproducible: Sometimes

Steps to Reproduce:
1) access some page in tab1
2) switch to tab2
3) wait until page in tab1 is fully downloaded
4) switch to tab1
5) access some hyperlink from that page
Actual Results:  
FF scrolls to top of current page

Expected Results:  
FF opens the hyperlink

1) Both accessibility features are turned on.
2) The problem reproducibility rate is about 15-20%

Please let me know if you need additional information.
(Reporter)

Updated

12 years ago
Summary: Sometimes FF jumps of top of current page instead of gollowing the URL → Sometimes FF jumps of top of current page instead of following the URL

Comment 1

12 years ago
(In reply to comment #0)
Please provide a specific URL where this happens.  (URL of the page with the link and the target for the link)
URL: n/a
Summary: Sometimes FF jumps of top of current page instead of following the URL → Sometimes FF jumps of top of current page instead of following the URL when clicking hyperlink
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> (In reply to comment #0)
> Please provide a specific URL where this happens.  (URL of the page with the
> link and the target for the link)
> 


As I said, the problem reproduces very randomly.
The URLs are mainly located inside our virtual network, so they will not be helpful to you. I have attached one webpage where the problem was seen several times. Last time I see the problem right now. On this page there are several anchors and internal links ("DetailedDescription", "Information", ...) - the problem is often seen with them. But yesterday I saw the problem with normal hyperlinks also.
(Reporter)

Comment 3

12 years ago
Created attachment 238852 [details]
Webpage example where the problem was seen several times
(Reporter)

Comment 4

12 years ago
Wow.
Right now I clicked just created Attachment link on this page (https://bugzilla.mozilla.org/attachment.cgi?id=238852) and the problem occurred!

Comment 5

12 years ago
Comment on attachment 238852 [details]
Webpage example where the problem was seen several times

I tried all the links in the row of links starting with history.  They all work fine in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20060915 BonEcho/2.0 and Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060523 Ubuntu/dapper Firefox/1.5.0.3 .
Not sure what your last comment means, but can you try the links from the page attached (accessing the bugzilla server instead of your own).
Also, according to your original bug description you are not using the latest build of Bon Echo.  Please grab one from ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8 and check with that.  (use firefox-2.0.en-US, not firefox-2.0b2.en-US)
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> (From update of attachment 238852 [details] [edit])
> I tried all the links in the row of links starting with history.  They all work
> fine in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20060915
> BonEcho/2.0 and Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3)
> Gecko/20060523 Ubuntu/dapper Firefox/1.5.0.3 .
> Not sure what your last comment means, but can you try the links from the page
> attached (accessing the bugzilla server instead of your own).
> Also, according to your original bug description you are not using the latest
> build of Bon Echo.  Please grab one from
> ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8 and
> check with that.  (use firefox-2.0.en-US, not firefox-2.0b2.en-US)
> 

My last comment means that the problem occurs sometimes even on current bugzilla page. For example to reply to your message I pressed "reply" link and for the first time it scrolled me up to top of page. For second time it worked fine.

As you suggested I will download latest release and inform you if the problem still exists. If I will not see the problem again in a few days I will inform you as well. Thank you.
(Reporter)

Comment 7

12 years ago
The problem is reproduced on
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060916 BonEcho/2.0

More observations:
1) the same issue sometimes occurs when trying to press webform buttons (for example - "Commit" button on this page)

2) The issue occurs only one time after the page is loaded. After trying to access the same url/button again it does not occur.

3) There is no need to switch between tabs as I have written in ordinal description. It does not affect the scenario.

4) There are 2 or more Bon Echo windows open. Each contains several tabs. Some of the pages contain embedded java applets.
(Reporter)

Comment 8

12 years ago
Should I try without accessibility options turned on?
I've never seen this. Please retest with disabled extensions (start Firefox in its safe-mode to disable them all at once) or with a new profile.
(Reporter)

Comment 10

12 years ago
This is not extension.
I mean: Tools->Options->Advanced->General->Accessibility. Both turned on.

I am going to switch "Always use cursor keys to navigate within pages" setting off and try to retest.
(Reporter)

Comment 11

12 years ago
Having 1.5 days of browsing with "Always use cursor keys to navigate within pages" turned off I do not observe the issue again.
So I am pretty sure the problem it in this feature.

Please let me know if you need additional information.

Comment 12

12 years ago
*** Bug 353309 has been marked as a duplicate of this bug. ***

Comment 13

12 years ago
Confirmed, same problem here (FF 2.0b2)!
Component: Tabbed Browser → Keyboard Navigation
QA Contact: tabbed.browser → keyboard.navigation
Summary: Sometimes FF jumps of top of current page instead of following the URL when clicking hyperlink → With caret browsing enabled, clicking a link sometimes jumps to top of the page instead

Comment 14

12 years ago
Bug is still present in RC1!

Comment 15

12 years ago
Bug is still present in RC2!
I've also seen this occasionally (on Mac), likely with caret browsing on. (I don't remember what version I was using at the time. Likely trunk).
OS: Windows XP → All
Hardware: PC → All

Comment 17

12 years ago
Can you guess it? It's still present in RC3.
(Reporter)

Comment 18

12 years ago
Looks like the issue is not present on  en-US; rv:1.8.1) Gecko/20061017 BonEcho/2.0.
It never occurred within 1 day of browsing.
(Reporter)

Comment 19

12 years ago
The issue reproduced 1 time within 2 days of browsing on en-US; rv:1.8.1) Gecko/20061017
BonEcho/2.0

I hit CTRL + Mouse-clicked the link and it jumped to top of page.

Reproducibility rate has decreased drastically, but it is still here...
(Reporter)

Comment 20

12 years ago
Reproduced 2 times so far on en-US; rv:1.8.1) Gecko/20061017
BonEcho/2.0...
(Reporter)

Comment 21

12 years ago
I found the exact scenario to reproduce the issue 100%.

1) Open content inside 2 tabs (0 and 1)
2) Stay on tab 1
3) Wait until both tabs are fully downloaded
4) Click some link on current tab (1) and while it is being downloaded switch to tab 0
5) Wait until tab 1 is completely downloaded
6) Switch to tab 1
7) Scroll page with mouse scroll button
8) Click some link -> It jumps to top of page.

Comment 22

12 years ago
bug 357617 has the same problem, it can be reproduced in frame all the time. See the test case in it.

Comment 23

12 years ago
dupe of bug 351491?
I think the patch of bug 144000 did the trick. Sorry for that.
But I don't understand why.

Comment 24

12 years ago

*** This bug has been marked as a duplicate of 351491 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 25

12 years ago
I had this bug and fixed it with the Accessibility trick; but that is not good for that Accessibility, especially since to fix it, someone has to spend a whole lot of time learning to navigate this site.
You need to log in before you can comment on or make changes to this bug.