click link on a new loaded frame page go to the top of the page with caret browsing on

RESOLVED DUPLICATE of bug 351491

Status

()

Firefox
Keyboard Navigation
RESOLVED DUPLICATE of bug 351491
12 years ago
12 years ago

People

(Reporter: Mike Gao, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

198 bytes, text/html
Details
(Reporter)

Description

12 years ago
I am using firefox2FC3 on winxpsp2. When I visit pages with frame, the first click on the link of the page does not work, but go to the top of the page. It will work  the second time. Will submit a test case.
(Reporter)

Comment 1

12 years ago
Created attachment 243126 [details]
Test Case

when the scroll bar appears, page down, click on any link.

Actual result:
the page go to the top.

Expected result:
go to the url the link points to.
Works fine for me, with that testcase.
(Reporter)

Comment 3

12 years ago
This happends with the latest trunk build on xp, but could not reproduce on Linux.
(Reporter)

Comment 4

12 years ago
(In reply to comment #2)
> Works fine for me, with that testcase.
> 

Are you sure it's the first click when you open the page? The second click will work fine for me.

And this happended when I clicked on "Commit" button to submit this comment just now.
Does it also happen when you press F7? I once saw this with caret browsing enabled.
(Reporter)

Comment 6

12 years ago
Yes. When caret browsing is on, both WinXP and Linux have such problem.
OS: Windows XP → All
Summary: click link on a frame page go to the top of the page → click link on a frame page go to the top of the page with caret browsing on
Version: 2.0 Branch → Trunk

Comment 7

12 years ago
See also bug 353005.
Keywords: testcase
(Reporter)

Comment 8

12 years ago
The problem disappeared when I disabled accessibility on Linux. I am changing the component to "Disability Access".
Component: General → Disability Access
QA Contact: general → disability.access
(Reporter)

Comment 9

12 years ago
(In reply to comment #8)
> The problem disappeared when I disabled accessibility on Linux. I am changing
> the component to "Disability Access".
> 

I could not reproduce this on my FC5 box  with the test case in this bug after run
gconftool-2 --type=bool --set /desktop/gnome/interface/accessibility false
to disable accessibility and run 
gconftool-2 --type=bool --set /desktop/gnome/interface/accessibility true
to enable a11y again. Trunk code.
(Reporter)

Comment 10

12 years ago
Maybe accessibility is not the key to reproduce this. But make sure don't click on the page before you click on the link. I think the reason why I could not reproduce this in comment #8 and #9 is that I clicked on the page to check if I enabled caret browsing before I click on the link.
(Reporter)

Comment 11

12 years ago
Moving to Keyboard Navigation.
Component: Disability Access → Keyboard Navigation
QA Contact: disability.access → keyboard.navigation
Summary: click link on a frame page go to the top of the page with caret browsing on → click link on a new loaded frame page go to the top of the page with caret browsing on

Comment 12

12 years ago

*** This bug has been marked as a duplicate of 351491 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.