Closed Bug 353134 Opened 15 years ago Closed 15 years ago

showing and hidding a div layer with a scrollbar leaves the scroll bar visible and active.

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 187435

People

(Reporter: enc, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

a div layer is created as hidden with overflow:auto and a fixed height so that a  vertical scrollbar appears when it is made visible. The div layer is made visible and then hidden again by javascript onclick events, but the scrollbar stays visible and working even though the contents of the div remain hidden.
It is part of a simple drop down menu system - some of these menus have scrollbars. 

Reproducible: Always

Steps to Reproduce:
1.create div: <div id="menu" style="overflow:auto;height:30em;width:12em;visibility:hidden:position:absolute;z-index:1000;top:-1000">menu items enough to make the scrollbars appear</div>
2.use onclick event to make menu div visible 
3.use onclick event to make menu div hidden

Actual Results:  
When the div is hidden again the scrollbars remain.

Expected Results:  
The scrollbars should not be visible if their div is hidden

I have tested this on the latest windows firefox (1.5.0.7) and it works fine so it is very likely to be a mac os x thing.
Example URL where this occurs:
http://adblock.jonasjohn.de/#a_filters

page has 7 vertical scroll bars visible on Mac. Same with Firefox 1.5.0.7 and 2.0 rc3 on OS X 10.4.8
I couldn't find a dup (but I suspect there might be one). I was able to reproduce on 2.0RC3 OS X.  Attaching a reduced testcase.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached file Simplified testcase
I think that this should be a dup of bug 187435.

*** This bug has been marked as a duplicate of 187435 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.