The default bug view has changed. See this FAQ.

UTC allday events sometimes shown in wrong day in agenda

RESOLVED DUPLICATE of bug 365034

Status

Calendar
Lightning Only
RESOLVED DUPLICATE of bug 365034
11 years ago
10 years ago

People

(Reporter: Sebastian Schwieger, Unassigned)

Tracking

({dataloss})

Trunk
dataloss

Details

(Reporter)

Description

11 years ago
I had some allday events in my calendar that don't contain timezone information in DTSTART and DTEND. Those are still shown correctly in the views but are wrong in agenda tree (todays event is shown for tomorrow).

Steps to reproduce:
1. import or create allday event that is stated in UTC format(see example below) or Europe/London 
2. change your timezone to Europe/Berlin
3. restart

Result: allday event is correct in the views (19.09.) but wrong in the agenda tree (Tomorrow)

Example:

BEGIN:VEVENT
CREATED:20060126T152941Z
LAST-MODIFIED:20060126T152941Z
DTSTAMP:20060126T152941Z
UID:uuid1127806490852
SUMMARY:Hausdienst
CLASS:PUBLIC
DTSTART;VALUE=DATE:20060224
DTEND;VALUE=DATE:20060225
PERCENT-COMPLETE:0
X-LIC-ERROR;X-LIC-ERRORTYPE=VALUE-PARSE-ERROR:No value for STATUS 
 property. Removing entire property:
CATEGORIES:Business
END:VEVENT

using Thunderbird2.0a and Lightning 2006091606 (WindowsXP)
(Reporter)

Comment 1

11 years ago
Sorry for confusion: the above example is actually not the one for 19.09. the correct example is following. Additionally, I would like to mention that this event has been created with Sunbird0.3a. So this is an upgrade issue.

BEGIN:VEVENT
CREATED:20060426T072000Z
LAST-MODIFIED:20060426T072009Z
DTSTAMP:20060426T072008Z
UID:uuid1146036009010
SUMMARY:Hausdienst
PRIORITY:0
CLASS:PUBLIC
DTSTART;VALUE=DATE:20060919
DTEND;VALUE=DATE:20060920
END:VEVENT

Comment 2

11 years ago
This could cause someone to miss an event, so we should at least consider making it block.
Flags: blocking0.3?
Keywords: dataloss

Updated

11 years ago
Keywords: relnote
Whiteboard: [cal relnote]

Updated

11 years ago
Summary: todays Allday event is shown for tomorrow in agenda (timezone problem) → UTC allday events shown in wrong day in agenda

Updated

11 years ago
Summary: UTC allday events shown in wrong day in agenda → UTC allday events sometimes shown in wrong day in agenda

Comment 3

11 years ago
Too late in the cycle to block; marking as blocking0.3-.
Flags: blocking0.3? → blocking0.3-

Comment 4

11 years ago
Confirmed per Bug 354946 Comment #2.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is a duplicate of bug 365034, which has a patch attached.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 365034

Updated

10 years ago
Keywords: relnote
Whiteboard: [cal relnote]
You need to log in before you can comment on or make changes to this bug.