floating all day event of today shown as tomorrow in Agenda

RESOLVED FIXED

Status

RESOLVED FIXED
12 years ago
6 years ago

People

(Reporter: notas, Assigned: martinschroeder)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

I imported the german holidays .ics file from mozilla (http://www.mozilla.org/projects/calendar/caldata/GermanHolidays.ics) the all day long events of today (holidays) are shown in the "tomorrow" category in the task menu.

Reproducible: Always

Steps to Reproduce:
1.import calendar 
2.wait for holiday day to come
3.



Expected Results:  
holidays of today should be today
(Reporter)

Comment 1

12 years ago
Created attachment 249689 [details]
screenshot of bug
I can confirm using Lightning/0.4a1 (2006122803) for the mentioned calendar and event:

    BEGIN:VEVENT
    CREATED:20061023T132504Z
    LAST-MODIFIED:20061023T132504Z
    DTSTAMP:20061023T132504Z
    UID:984536863
    SUMMARY:2. Weihnachtstag
    STATUS:CONFIRMED
    CLASS:PUBLIC
    RRULE:FREQ=YEARLY;INTERVAL=1;BYMONTH=12
    DTSTART;VALUE=DATE:20061226
    DTEND;VALUE=DATE:20061227
    URL:http://sunbird.erweiterungen.de/
    DESCRIPTION:Christlicher Feiertag.
    CATEGORIES:Feiertag
    X-MOZILLA-RECUR-DEFAULT-UNITS:years
    END:VEVENT

It seems that the Agenda has problem with the floating timezone. If I open and save the event with Europe/Berlin timezone the event is shown on correct section in Agenda.
Status: UNCONFIRMED → NEW
Component: General → Lightning Only
Ever confirmed: true
OS: Windows XP → Windows 2000
QA Contact: general → lightning
Summary: all day events of today shown as tomorrow with holiday calendar → floating all day event of today shown as tomorrow in Agenda
Version: unspecified → Lightning 0.3
(Assignee)

Comment 3

12 years ago
Created attachment 252940 [details] [diff] [review]
Patch v1

http://lxr.mozilla.org/seamonkey/source/calendar/lightning/content/agenda-tree.js#278 was not aware of an item's timezone.
Assignee: nobody → mschroeder
Status: NEW → ASSIGNED
Attachment #252940 - Flags: second-review?(dmose)
Attachment #252940 - Flags: first-review?(jminta)
(Assignee)

Updated

12 years ago
OS: Windows 2000 → All
Hardware: PC → All
Version: Lightning 0.3 → Trunk
(Assignee)

Updated

12 years ago
Duplicate of this bug: 353307

Comment 5

12 years ago
Comment on attachment 252940 [details] [diff] [review]
Patch v1

r1/r2=jminta  Thanks for the patch!
Attachment #252940 - Flags: second-review?(dmose)
Attachment #252940 - Flags: second-review+
Attachment #252940 - Flags: first-review?(jminta)
Attachment #252940 - Flags: first-review+

Comment 6

12 years ago
Patch checked in.
  calendar/lightning/content/agenda-tree.js: 1.28 -> 1.29
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.