character escaping issues cause data corruption

RESOLVED WORKSFORME

Status

Calendar
General
--
major
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: dmose, Unassigned)

Tracking

({dataloss})

Trunk
Sunbird 0.5
x86
Windows XP
dataloss

Details

(Reporter)

Description

11 years ago
In the event dialog, add text to the beginning of the Description field that has a : in it, such as:

mgmt: foo

Reload the calendar, and look at the Description field again.  It will have a bunch of hex glop inserted into the beginning of the field.  

This definitely happens in the ICS provider, it might well happen in others.

4.3.11 of RFC 2445 defines the various characters that need escaping.  

Marking qawanted, as it would be helpful to understand whether there are other places besides the event dialog that have this problem (eg unifinder, inline text editing widget in the views, etc.).
(Reporter)

Updated

11 years ago
Flags: blocking0.3+
Whiteboard: [needs patch][needs testing]

Comment 1

11 years ago
Why is this a blocker? 
Sure, this is ugly, but no really a showstopper for a *0.3* application.
Flags: blocking0.3+ → blocking0.3?

Comment 2

11 years ago
Works for me using Sunbird 0.3a2+ (2006-09-22-01).

I created an event in ics calendar (local disk) and in storage calendar that contained the title and description "mgmt: foo : / \ ? ; ,". 
After doing various restart, reload, export, import actions I don't saw any problems. Title and description were displayed fine.

4.3.11 of RFC 2445 defines:

     text       = *(TSAFE-CHAR / ":" / DQUOTE / ESCAPED-CHAR)
     ; Folded according to description above

     ESCAPED-CHAR = "\\" / "\;" / "\," / "\N" / "\n")
        ; \\ encodes \, \N or \n encodes newline
        ; \; encodes ;, \, encodes ,

The ics contains:
  SUMMARY:mgmt: foo : / \\ ? \; \,
  DESCRIPTION:mgmt: foo : / \\ ? \; \,

So encoding is done properly.

Maybe a server side issue?
(Reporter)

Updated

11 years ago
Flags: blocking0.3? → blocking0.3-
(Reporter)

Updated

11 years ago
Target Milestone: Sunbird 0.3 → Sunbird 0.5
This WFM also. I believe it's truly a dupe of bug 268042.

Comment 4

11 years ago
Dmose can you address ssiter's comment above? Are you still seeing this issue with the nightly builds?
(Reporter)

Comment 5

11 years ago
I'm not seeing this anymore.  I suspect it may well have been a server-side problem that was fixed in recent upgrades to mod_dav_svn or subversion itself.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Whiteboard: [needs patch][needs testing]
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.