Open Bug 354004 Opened 14 years ago Updated 5 years ago

with --enable-javaxpcom , compilation of nsJavaInterfaces.cpp doesn't find nsXULAppAPI.h

Categories

(Core Graveyard :: Java to XPCOM Bridge, defect)

PowerPC
macOS
defect
Not set

Tracking

(Not tracked)

UNCONFIRMED

People

(Reporter: jfm, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/418.8 (KHTML, like Gecko) Safari/419.3
Build Identifier: seamonkey-1.0.5 - built from src

w/o "--enable-javaxpcom", correct build and reliable pkg. But adding it breaks the build with:
c++ -o nsJavaInterfaces.o -c  -DMOZILLA_INTERNAL_API -DOSTYPE=\"Darwin8.7.1\" -DOSARCH=\"Darwin\" -DBUILD_ID=0000000000 -I/System/Library/Frameworks/JavaVM.framework/Headers -I/System/Library/Frameworks/JavaVM.framework/Headers/linux -I. -I../../../../dist/include/xpcom -I../../../../dist/include/string -I../../../../dist/include/xulapp -I../../../../dist/include/javaxpcom -I../../../../dist/include -I../../../../dist/include/nspr    -I../../../../dist/sdk/include -I/usr/X11R6/include   -fPIC  -I/sw/include/cairo  -I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -no-cpp-precomp -fno-common -fshort-wchar -pipe  -DNDEBUG -DTRIMMED -O3  -I/sw/include/cairo  -I/usr/X11R6/include -DMOZILLA_CLIENT -include ../../../../mozilla-config.h -Wp,-MD,.deps/nsJavaInterfaces.pp ./../nsJavaInterfaces.cpp
./../nsJavaInterfaces.cpp:51:25: error: nsXULAppAPI.h: No such file or directory
./../nsJavaInterfaces.cpp: In function 'nsresult InitEmbedding_Impl(JNIEnv*, _jobject*, _jobject*, _jobject*)':
./../nsJavaInterfaces.cpp:84: error: 'XRE_InitEmbedding' was not declared in this scope
./../nsJavaInterfaces.cpp: In function 'void Java_org_mozilla_xpcom_internal_GREImpl_termEmbedding(JNIEnv*, _jobject*)':
./../nsJavaInterfaces.cpp:107: error: 'XRE_TermEmbedding' was not declared in this scope

The following shows that it could not be found, given the -I flags (there is no symlink under dist) :
/sw/.bld/seamonkey-1.0.5-1/mozilla root# find . \( -name nsXULAppAPI.h -o -name nsJavaInterfaces.cpp \) -ls
36665268   12 -rw-r--r--   1 root     admin        8797 Jan  6  2006 ./extensions/java/xpcom/nsJavaInterfaces.cpp
36650339   12 -rw-r--r--   1 root     admin        9146 Jan  6  2006 ./toolkit/xre/nsXULAppAPI.h

With some previous version I had tried to fix this problem (probably by adding an appropriate symlink);
then compilation continued OK, but I ran into (corresponding) undefined symbols: it seems javaxpcom really depends on some other parts. Trying to add --enable-libxul in the hope this might fix it ran into a refusal by configure...


Reproducible: Always

Steps to Reproduce:
1. build with (eg) ConfigureParams: --enable-xft --disable-freetype2 --enable-calendar --enable-optimize="-O3" --disable-debug --enable-application=suite --enable-macos-target=10.4 --enable-default-toolkit=gtk2 --with-pthreads --with-default-mozilla-five-home=%p/lib/%N --mandir=%p/share/man --enable-strip --enable-extensions=all --enable-image-decoders=all --enable-ldap-experimental --enable-necko-protocols=all --enable-ctl --enable-xinerama --with-system-mng --with-system-jpeg --with-system-png --with-system-zlib --enable-postscript --enable-ipv6 --enable-tests --with-x --enable-canvas --with-qtdir=%p --enable-pango --enable-svg --enable-update-packaging --enable-storage --enable-system-cairo --enable-profilesharing --enable-svg-renderer=cairo --enable-cplus --enable-javaxpcom
2.
3.

Actual Results:  
build fails

Expected Results:  
build succeeds
bug persists with seamonkey-1.1a
Can you reproduce with SeaMonkey v1.1.9 ?
Version: unspecified → SeaMonkey 1.1 Branch
Yes

Jean-Francois
Can you reproduce with SeaMonkey v2.0a1pre ?
Flags: blocking-seamonkey1.1.11?
Things that only happen with a special, non-default build configuration don't block a release.
Flags: blocking-seamonkey1.1.11? → blocking-seamonkey1.1.11-
QA Contact: build-config → build-config
Assignee: nobody → jhpedemonte
Component: Build Config → Java to XPCOM Bridge
Flags: blocking-seamonkey1.1.11-
Product: SeaMonkey → Core
QA Contact: build-config → xpcom-bridge
Version: SeaMonkey 1.1 Branch → Trunk
Assignee: jhpedemonte → nobody
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.