Autocomplete fails when only one item for letter

VERIFIED FIXED in Camino1.5

Status

Camino Graveyard
Location Bar & Autocomplete
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: jt.marsh, Assigned: Håkan Waara)

Tracking

({fixed1.8.1})

unspecified
Camino1.5
PowerPC
Mac OS X
fixed1.8.1
Bug Flags:
camino1.5 +

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a1) Gecko/20060923 Camino/1.2+
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a1) Gecko/20060923 Camino/1.2+

I no longer get any url suggestions when typing in the URL bar.

Reproducible: Always

Steps to Reproduce:
Start typing a URL.
Actual Results:  
No suggestions.

Expected Results:  
Suggestions.

I have:

user_pref("browser.urlbar.matchOnlyTyped", true);

if that makes any difference.
Using Version 2006092321 (1.2+), this WFM.

Where did you get this build from? Is this your own build or a tinderbox build? (There isn't an nightly from 09/23 yet.)

Comment 2

12 years ago
This was fixed in CVS the evening of the 21st, and works in the 22 September nightly build as well.

cl
(Reporter)

Comment 3

12 years ago
This is my own build. My own build from a few nights earlier worked.

It does seem to be selective about when it works and when it doesn't. Sometimes maybe it is just slow. For instance I type 'm' and I get 2 suggestions, "maps.google.com" and "mozillazine.org". Then I type the 'o', and I get nothing, but if I retry and wait longer, mozillazine shows up.

If I type www.digg.com and go to digg, then type 'w' or 'd' in the URL bar, I get nothing. If I then type in "digg.com" and go to digg, then type 'd', "www.digg.com" and "digg.com" show up as a suggestions.

If I type 'n', I get no suggestions. If I type in "netscape.com" and go to netscape, then type 'n', I get 2 suggestions, "netscape.com" and "news.mozilla.org".

If I type slowly, n   e, I get "news.mozilla.org" and "netscape.com" as suggestions. If I type normal speed 'new', I get no suggestions. If I delete the 'w', I get 2 suggestions "news.mozilla.org" and "netscape.com". Same thing for typing "net" at normal speed.

Other things refuse to show up as suggestions - for instance "webmail.hawaii.rr.com".







For other URL's it does not work at all.
(Assignee)

Comment 4

12 years ago
Please download today's latest nightly, and re-try. Lots of changes have been made to autocomplete lately, so it is critical that we know exactly when your build / source code is from.
(Reporter)

Comment 5

12 years ago
Also "bugzilla.mozilla.org" never shows up as a suggestion. Maybe bugzilla and webmail.hawaii.rr.com don't ever show up as suggestions because they are https?
(Reporter)

Comment 6

12 years ago
I downloaded a tinderbox build and get the same thing. I tried to rebuild and the build fails -- something about an invalid cast size_t to type PRUint32.
(Assignee)

Comment 7

12 years ago
Please be more specific:

* Can you post a link to exactly which build you tried?
* Does it work if you move away your application support/Camino folder, and try on a fresh profile?
* Can you give us exact steps to reproduce, so anyone can reproduce? We need example URIs, preferably on a fresh profile (see above).

I would guess that the source in your local tree is somehow horked (if it doesn't compile, while there's a green tree), so let's go the route of using nightlies instead.
(Reporter)

Comment 8

12 years ago
Seems comment #3 and #5 is pretty specific about URL's I am using. What more are your looking for?

I saw red in the tinderbox with the same invalid cast errors. I am rebuilding again now.
(Reporter)

Comment 9

12 years ago
Correction to #5. bugzilla.mozilla.org do not show up as long as there is only 1 possible suggestion starting with 'b'. If I add another possibility by typing in "ballbug.com", then when I type 'b', I get 2 suggestions -- "bugzilla.mozilla.org" and "ballbug.com". But again if I type at normal speed "bu" or "ba", I get no suggestions.
Confirming based on comment 9.

We talked about this on IRC previously and I don't think there's a bug on this specific issue. The other related bug is bug 354070.

This is Håkan's bug as well.
Assignee: nobody → hwaara
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: camino1.1a1?
Flags: camino1.1+
Summary: Autocompletion is broken → Autocomplete fails when only one item for letter
Target Milestone: --- → Camino1.1
(Assignee)

Comment 11

12 years ago
Created attachment 240332 [details] [diff] [review]
Fix

I optimized this code by only sorting if there were more than 1 result, but accidently also wrapped the call that adds results to the out-array inside the same block, so 1 result would never be appended (2 would).

I think this fixes bug 354070 as well
Attachment #240332 - Flags: superreview?(sfraser_bugs)
(Reporter)

Comment 12

12 years ago
I just found this as well and the fix does fix the problems I am seeing.

Updated

12 years ago
Attachment #240332 - Flags: superreview?(sfraser_bugs) → superreview+
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
(Assignee)

Comment 13

12 years ago
*** Bug 354070 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.