Not Enough Arguments exception when using "Search the Internet" on Vista

RESOLVED FIXED

Status

()

Firefox
Shell Integration
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

({fixed1.8.1, regression})

2.0 Branch
x86
Windows Vista
fixed1.8.1, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Bug 341405 added the capability to search using start -> enter search term -> click Search the Internet on Vista. I get a Not Enough Arguments exception when using this now on Vista. Patch coming up
Created attachment 239976 [details] [diff] [review]
simple patch
Attachment #239976 - Flags: review?(gavin.sharp)
Comment on attachment 239976 [details] [diff] [review]
simple patch

Ah, yeah, this happened because I reviewed the patch for bug 341405 before the patch for bug 340857 landed, but bsmedberg checked it in after the patch for bug 340857.

We should probably fix this on the branch too...
Attachment #239976 - Flags: review?(gavin.sharp) → review+
Comment on attachment 239976 [details] [diff] [review]
simple patch

Drivers, simple fix to enable using "Search the Internet" on Vista
Attachment #239976 - Flags: approval1.8.1?
Checked in to trunk
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Comment on attachment 239976 [details] [diff] [review]
simple patch

a=beltzner on behalf of drivers
Attachment #239976 - Flags: approval1.8.1? → approval1.8.1+
Checked in to MOZILLA_1_8_BRANCH
Keywords: fixed1.8.1
You need to log in before you can comment on or make changes to this bug.