Background of bookmarks toolbar doesn't properly handle taller items

VERIFIED FIXED in Firefox 2

Status

()

defect
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: bart, Assigned: philor)

Tracking

({verified1.8.1})

2.0 Branch
Firefox 2
PowerPC
macOS
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(6 attachments)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0

This wasn't an issue in previous version of Firefox until the new theme was introduced in Firefox 2 beta 2. The background image used for the bookmarks toolbar can't properly handle items that are taller than the bookmark text. This is an issue with the Google Browser Sync extension which places things in the toolbar that increase its height.

It's also a problem with the FireBug extension which uses the same background image for its toolbar, though that may need to be something that extension's developer needs to address himself. My screenshot (see URL) includes both.

Reproducible: Always
Blocks: NewTheme
Multiple screenshots to come, more if you have other ideas you want to see shot.
Assignee: nobody → philringnalda
Status: UNCONFIRMED → ASSIGNED
Attachment #240267 - Flags: review?(mconnor)
Attachment #240267 - Flags: approval1.8.1?
*** Bug 354377 has been marked as a duplicate of this bug. ***
Target Milestone: --- → Firefox 2
Version: unspecified → 2.0 Branch
Posted image Current default
The current default state, plus a button on the toolbar. Note that (due to a bug I don't remember, but am probably cc'ed on anyway) to reproduce you need to have changed your icon size at least once: if you start with default large icons, and add a button to the ptf, you get a small icon there, but once you change the nav toolbar to small icons, then the ones on the ptf will change size along with the others.
Posted image Current worst-case
We're looking particularly awful if you have large icons plus text.
Posted image Fixed, large icons
Posted image Fixed, small icons
Posted image Fixed, icons + text
Low low risk, high high yield. You're in.
Flags: blocking-firefox2? → blocking-firefox2+
Attachment #240267 - Flags: review?(mconnor)
Attachment #240267 - Flags: review+
Attachment #240267 - Flags: approval1.8.1?
Attachment #240267 - Flags: approval1.8.1+
1.8: mozilla/browser/themes/pinstripe/browser/browser.css 1.11.4.50
trunk: mozilla/browser/themes/pinstripe/browser/browser.css 1.32
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
verified with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20060928 BonEcho/2.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.