nsMicrosummaryService.js not regenerated when enabling/disabling Places

RESOLVED FIXED

Status

Firefox Graveyard
Microsummaries
RESOLVED FIXED
11 years ago
a year ago

People

(Reporter: db48x, Assigned: db48x)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

11 years ago
the dialog that asks for the title and location comes up, but clicking on the add button doesn't do anything. Here are the js errors I see:

Error: ServiceManager::GetService returned failure code: = NS_ERROR_XPC_GS_RETURNED_FAILURE
Source file: chrome://browser/content/browser.js
Line: 1427

Error: Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]
Source file: file:///home/db48x/moz/mozilla/firefox-opt-i686-pc-linux-gnu/dist/bin/components/nsMicrosummaryService.js
Line: 637

Based on something philor mentioned on IRC, this may be a dup. Better to record it while I'm thinking of it though.
User Agent String?
Not a dupe of mine, I was waiting for someone with more build-fu to tell me whether I just didn't know what I was doing. After Vlad turned Places off, I did a "make -f client.mk clobber" and "make -f client.mk build" and near as I could tell, everything that needed to know about #ifdef MOZ_PLACES was rebuilt, except for the copy of nsMicrosummaryService.js sitting in my objdir, refusing to go away until I rm'ed it. (Mac and Linux, so -> All)
OS: Linux → All
Hardware: PC → All
Component: Bookmarks → Microsummaries
QA Contact: bookmarks → microsummaries
Summary: add bookmark doesn't work → nsMicrosummaryService.js not regenerated when enabling/disabling Places
(Assignee)

Comment 3

11 years ago
in my case the build id is 20060927.

Phil: that description helps, yes. Looking at the Makefile, there's no way for make to know it ought to have rebuilt it. I think there's a better way of preprocessing a js component that would handle this automatically, but I'll have to look. Alternately, bsmedberg can probably tell us, so I'll cc him.

Barring that, making it a phony target would also work.
Assignee: nobody → db48x
(Assignee)

Comment 4

11 years ago
EXTRA_PP_COMPONENTS maybe? EXTRA_something_COMPONENTS I'm sureā€¦
Status: NEW → ASSIGNED
EXTRA_PP_COMPONENTS should work
(Assignee)

Comment 6

11 years ago
Created attachment 240326 [details] [diff] [review]
354449-1.diff

actually, EXTRA_PP_COMPONENTS won't work because the file was checked in with the .in extension. I've added a comment to that effect.
Attachment #240326 - Flags: review?(benjamin)
(Assignee)

Comment 7

11 years ago
and the patch does indeed fix the bug.
If EXTRA_PP_COMPONENTS is the right fix, then we should just get a CVS admin like Dave Miller to move the file for us.
Comment on attachment 240326 [details] [diff] [review]
354449-1.diff

What myk said. You can you my client-side script to do the move if that's easier.
Attachment #240326 - Flags: review?(benjamin) → review-
(Assignee)

Comment 10

11 years ago
Created attachment 240440 [details] [diff] [review]
354449-2.diff

Presumes nsMicrosummaryService.js gets moved in some fashion.
Attachment #240440 - Flags: superreview?
Attachment #240440 - Flags: review?(benjamin)
(Assignee)

Updated

11 years ago
Attachment #240326 - Attachment is obsolete: true
Attachment #240440 - Flags: superreview?
Attachment #240440 - Flags: review?(benjamin)
Attachment #240440 - Flags: review+
Depends on: 366882
The cvs copy for this bug made the tree red because of a CVS conflict.  The choices are back out the move, or check this in and trigger a clobber build.

Question: does nsMicrosummaryService.js.in need to get removed also? (The cvs copy was just a copy, the original is still there until deleted)

Comment 12

11 years ago
Checking in Makefile.in;
/cvsroot/mozilla/browser/components/microsummaries/src/Makefile.in,v  <--  Makefile.in
new revision: 1.2; previous revision: 1.1
done

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(In reply to comment #11)
> Question: does nsMicrosummaryService.js.in need to get removed also? (The cvs
> copy was just a copy, the original is still there until deleted)

As far as I know, this ^^ still hasn't been done.  So if it needs to be, don't forget. :)
> As far as I know, this ^^ still hasn't been done.  So if it needs to be, don't
> forget. :)

Yup.  I have CVS removed the file after getting r=gavin on IRC.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.