Closed Bug 354465 Opened 13 years ago Closed 13 years ago

Ability to remember username and password for CalDav calendar is lost

Categories

(Calendar :: Sunbird Only, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sebo.moz, Assigned: mattwillis)

References

Details

(Keywords: regression)

Attachments

(1 file)

If you subscribe to a CalDAV calendar you cannot choose that Sunbird should remember username and password (checkbox). This is a regression as it worked up to Sunbird 20060919. It fails from Sunbird 20060920 on.

STR:

1. subscribe to CalDAV calendar
2. enter username and password in pop up dialog

Result: There is no checkbox to remember the entered information

using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060927 Calendar/0.3a2+
This was due to the checkin for bug 351199
mozilla/calendar/providers/caldav/calDavCalendar.js 1.68

If we remove the if case for Components.interfaces.nsIAuthPrompt2, the checkbox returns. 

Once dmose arrives, I'll chat with him about how we want to handle this.
Assignee: nobody → lilmatt
Attachment #240360 - Flags: first-review?(cmtalbert)
Attachment #240360 - Flags: first-review?(cmtalbert) → first-review+
Comment on attachment 240360 [details] [diff] [review]
rev0 - Fix nsiAuthPrompt2 and remove unnecessary nsIDocTreeShell reference

r=dmose
Attachment #240360 - Flags: second-review?(dmose) → second-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: NEW → RESOLVED
Closed: 13 years ago
Depends on: 354522
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.