[Mac] scroll bar from overflow:scroll element appears on top of position:absolute elements

RESOLVED DUPLICATE of bug 187435

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 187435
12 years ago
11 years ago

People

(Reporter: Collin Grady, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

Situation: Two elements, one with overflow:scroll and one with position:absolute, where the first has more content than it can hold, and has a scrollbad, and the second is positioned over the first.

The scrollbar is appearing on top of the second element, when it should be below. This problem only presents itself on OSX.

In 1.5, setting the second element to fixed stops the scrollbar from being on top, but results in unwanted behavior on the second element regarding positioning.

In 3.0a, aka Minefield, the scrollbar even appears on top of the fixed element.

Reproducible: Always

Steps to Reproduce:
1. Visit http://geekforhire.org/tests/firefox-osx-overflow-bug.xhtml

Actual Results:  
Scrollbar is on top of blue box.

Expected Results:  
Scrollbar should be below blue box.

Comment 1

12 years ago
Happens for me too.  I'm running firefox 2.0 (also on OS X 10.4) but don't have authority to change the version info (should I just do this or post a new bug and mark as dup to add the version info to the meta-data?)

Here is another example:

http://neatfonts.com/  Click on the browse category button.

Comment 2

12 years ago
Bug187435 might relate.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 187435
You need to log in before you can comment on or make changes to this bug.