drag a file with a .URL extension.

RESOLVED FIXED

Status

Camino Graveyard
Drag & Drop
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: 7leonn, Assigned: Wevah)

Tracking

({fixed1.8.0.9, fixed1.8.1})

unspecified
PowerPC
Mac OS X
fixed1.8.0.9, fixed1.8.1

Details

Attachments

(2 attachments, 3 obsolete attachments)

2.76 KB, patch
Stuart Morgan
: review+
Simon Fraser
: superreview+
Details | Diff | Splinter Review
2.88 KB, patch
froodian (Ian Leue)
: review+
Smokey Ardisson (offline for a while; not following bugs - do not email)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060911 Camino/1.0.3 (MultiLang)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060911 Camino/1.0.3 (MultiLang)

I drag this link on camino, and it downloads itself (the .URL bookmark) again and again. Camino is unusable ans my downloads folder is overhelmed with this auto-duplicating file. Safari does well with the .URL bookmark.

Reproducible: Always

Steps to Reproduce:
1.drag the .URL to camino
2.Let it bug
3.Force to quit



Expected Results:  
open the embedded url of the .URL file

I wish I could upload you a .URL bookmark for you to investigate on this issue.
(Reporter)

Comment 1

11 years ago
the .URL file, opened with textedit is (for example):
[InternetShortcut]

URL=http://www.laserpod.com/introduction.asp

and the filename (open with camino by default)is:
laserpod.URL
(Assignee)

Comment 2

11 years ago
Change the extension from .URL to .url and it will work. However, I should probably make the extension check case-insensitive. Taking.
Assignee: nobody → mozilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

11 years ago
Created attachment 240828 [details] [diff] [review]
The fix.

The fix is to lowercase the file extension before the isEqualToString: calls.
Attachment #240828 - Flags: review?
(Assignee)

Comment 4

11 years ago
Severity -> normal.

I don't see any auto-duplication, and the fix is trivial, so...
Severity: critical → normal
(Assignee)

Comment 5

11 years ago
Created attachment 240834 [details] [diff] [review]
The fix, v2.

Oops, I missed the one in MainController.mm.
Attachment #240828 - Attachment is obsolete: true
Attachment #240834 - Flags: review?(stridey)
Attachment #240828 - Flags: review?

Updated

11 years ago
Attachment #240834 - Flags: superreview?(sfraser_bugs)
Attachment #240834 - Flags: review?(stridey)
Attachment #240834 - Flags: review+
(Assignee)

Comment 6

11 years ago
Created attachment 240835 [details] [diff] [review]
-u version of v2.

r+ as per froodian on IRC.
Attachment #240834 - Attachment is obsolete: true
Attachment #240835 - Flags: review+
Attachment #240834 - Flags: superreview?(sfraser_bugs)
(Assignee)

Comment 7

11 years ago
Created attachment 240841 [details] [diff] [review]
v3: Add BookmarkManager.mm, too.

Fixing up the BM manager too, so we don't have to worry about it later (per smorgan).
Attachment #240835 - Attachment is obsolete: true

Comment 8

11 years ago
Comment on attachment 240841 [details] [diff] [review]
v3: Add BookmarkManager.mm, too.

r=me
Attachment #240841 - Flags: superreview?(sfraser_bugs)
Attachment #240841 - Flags: review+

Updated

11 years ago
Attachment #240841 - Flags: superreview?(sfraser_bugs) → superreview+
This looks simple enough to consider for 1.0.4 when the time comes.
Flags: camino1.0.4?
Whiteboard: [needs checkin]

Comment 10

11 years ago
Checked in on trunk and 1.8branch
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [needs checkin]
This patch fails to apply on the 1.8.0 branch.  

If someone whips up a 180branch-compatible patch, we'll consider this for 1.0.4.
(Assignee)

Comment 12

11 years ago
I'll have to check out that branch, but I should be able to do it.
(Assignee)

Comment 13

11 years ago
Created attachment 248433 [details] [diff] [review]
Patch for 1.8.0 branch
(Assignee)

Updated

11 years ago
Attachment #248433 - Flags: review?(stridey)
Comment on attachment 248433 [details] [diff] [review]
Patch for 1.8.0 branch

I tested this, and it works as expected (within the confines of bug 363654 on the 1.8.0 branch and bug 363633 everywhere).
Attachment #248433 - Flags: review+
Flags: camino1.0.4? → camino1.0.4+

Comment 15

11 years ago
Comment on attachment 248433 [details] [diff] [review]
Patch for 1.8.0 branch

r=me.  Since the differences are redonkulous, foregoing a second sr.  If anybody disagrees, they should speak up before I get to checkins.
Attachment #248433 - Flags: review?(stridey) → review+

Updated

11 years ago
Whiteboard: [Needs Checkin 1.8.0branch]

Comment 16

11 years ago
Checked in on 1.8.0branch (forgot bug number in checkin comment, search for "robustification")
Keywords: fixed1.8.0.9
Whiteboard: [Needs Checkin 1.8.0branch]
You need to log in before you can comment on or make changes to this bug.