Closed Bug 355304 Opened 14 years ago Closed 13 years ago

Exceptions of recurring events are not handled by export to iCalendar

Categories

(Calendar :: Import and Export, defect, P1, major)

Tracking

(Not tracked)

RESOLVED FIXED
Sunbird 0.3

People

(Reporter: sebo.moz, Assigned: mvl)

Details

(Keywords: dataloss)

Attachments

(2 files)

When exporting a storage calendar to iCalendar format recurring events loose any exceptions.

Steps to reproduce:
1. create daily recurring event (5 times)
2. drag first occurrence one week ahead
3. export whole calendar, choose iCalendar format

Result: no exceptions in ics file. After importing the data again, the exeptions are not shown.

found using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061002 Sunbird/0.3
This is in conflict with "Export should serialize all data into the file" from the release status file. Requesting blocking0.3
Flags: blocking0.3?
I can reproduce this on Lightning 0.3rc 1 (2006100209), Thunderbird 1.5.7 (20060909), on Mac PPC OSX 10.4
losing data on export is bad.
Flags: blocking0.3? → blocking0.3+
Attached patch patch v1Splinter Review
Copied the code from the ics provider. One day, we will share this code...
Assignee: nobody → mvl
Status: NEW → ASSIGNED
Attachment #241187 - Flags: first-review?(dmose)
Comment on attachment 241187 [details] [diff] [review]
patch v1

Looks good; r=dmose.
Attachment #241187 - Flags: first-review?(dmose) → first-review+
Whiteboard: [needs checkin]
Target Milestone: --- → Sunbird 0.3
Priority: -- → P1
patch checked in, moved the SUNBIRD_0_3_RELEASE tag
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Whiteboard: [needs checkin]
Whiteboard: [litmus testcase wanted]
well, can not verify -> REOPEN

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061217 Calendar/0.4a1

1. create event from tomorrow, per 5 days (no matter if I set daily or not)
2. move first occurence to next hour (use week view)
3. export calendar
4. delete events
5. import exported calendar

result: error - 1 item failed to import
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Sunbird 0.3 → ---
(In reply to comment #7)
> well, can not verify -> REOPEN
> result: error - 1 item failed to import

This bug is about export. Does the export worked as expected after this fix?
If you see an error during import this is a complete different problem and I think you should file a new bug.
(In reply to comment #9)

> This bug is about export. Does the export worked as expected after this fix?
That's the problem. I'm not able to verify if exception was exported properly so I exported calendar and wanted to import to check if is is the same

> If you see an error during import this is a complete different problem and I
> think you should file a new bug.
Yes, error is displayed when I try to import

Ok, if you think that exported data looks good, please close it, mark as fixed (because bug is fixed) and let me open new issue
Using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a2pre) Gecko/20061219 Calendar/0.4a1:

I created repeating event, deleted one occurrence and exported to iCalendar file. I checked the file and the EXDATE elements are there.

-> Setting back to FIXED.

Damian, please file a new bug on the import issue. 
(Note: If you just open your exported file as new calendar it works ok)
Status: REOPENED → RESOLVED
Closed: 14 years ago13 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → Sunbird 0.3
I filed Bug 364388 for the import issue.
Flags: in-litmus?
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.