Remove "netscape" from prog-ids

VERIFIED DUPLICATE of bug 37275

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 37275
18 years ago
13 years ago

People

(Reporter: BenB, Assigned: Chris Waterson)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
A lot (all) of our prog-ids are still in the netscape "domain", e.g.
"component://netscape/editor/htmleditor". Change all of them to "mozilla".
(Reporter)

Comment 1

18 years ago
Is <quote
src="http://lxr.mozilla.org/seamonkey/source/netwerk/streamconv/public/nsIStreamConverter.idl#117">#define
NS_ISTREAMCONVERTER_KEY "Software/Netscape/streamconv/"</quote> covered by this
bug?
(Reporter)

Updated

18 years ago
Blocks: 35548
(Assignee)

Comment 2

18 years ago
this is ridiculous.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

18 years ago
Using "netscape" as domain implieis, that the component belongs to NSCP, which
is wrong - it belongs to Mozilla. I don't know, why "netscape" ever made it in
in this way.

(Note, that this bug doesn't necessarily has to be fixed by you.)

> this is ridiculous.

Can you explain, please?
(Assignee)

Comment 4

18 years ago
i think we should come to consensus in n.p.m.xpcom about what progids should 
look like.

news://news.mozilla.org/38F61824.615CF4C2%40netscape.com
(Assignee)

Comment 5

18 years ago
As to ridiculous. This bug is ridiculous if the point is the wanton removal of 
the word "netscape" from the source tree. In the old (?) ProgID scheme, the 
first part of the path was the vendor that provided the component 
implementation. In which case, "netscape" is perfectly valid as the contributor 
of the implementation for a component.

If the point of the bug is to fix ProgIDs to some new and better scheme (which, 
by the way, doesn't mention vendor), then I'd like to 1) hear the merits of the 
new scheme, and 2) get buy in from people that they'll actually fix the code. 
Otherwise, we'll just have a messed up mix of old and new ProgIDs that'll be 
even more confusing than a single broken scheme.
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Comment 6

18 years ago
There'S a new bug on this with a lot of discussion.
(Reporter)

Comment 7

18 years ago

*** This bug has been marked as a duplicate of 37275 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
Chris, Netscape is not the vendor for Mozilla components. Mozilla is the vendor.
Netscape is the contributor.

Comment 9

18 years ago
moving from architecture product to Browser. Architecture product is going
away.
Component: All → Browser-General
Product: Architecture → Browser
Version: 5.0 → other

Comment 10

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.