Messages are not downloaded completly using IMAP and Microsoft Exchange IMAP4rev1 server version 5.5.2658.34

RESOLVED DUPLICATE of bug 92111

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 92111
12 years ago
10 years ago

People

(Reporter: Catalin Sanda, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: version 3 alpha 1 (20061006)

Using the latest nightly build and a new profile, I try to open an email (the email which I will use as an example has 183KB, as reported by outlook express), which originally has 4 pictures as attachments but thunderbird sees 3, and the third image is not downloaded completely but is truncated at some point.

The message in outlook ends with this:

qze38l3DGkoG5CeR3oooGmymei+uKUn5cKPqaKKBCfU1PaypFOjurEA5O04NFFAHceKdU8Na7oNt
LBeaymtwqEaO9ZZYio7Kw5H0xXD2Ufm3UcJxh2xRRQxrc0L7RZYSWh+dPTvWSylThgQfQ0UVEJNr
UupFJ6CGkzRRVmYZzS0UUAFJnHSiigAGDS9qKKACiiigCSJtp5ooooA//9k=

------_=_NextPart_000_01C6E931.841A2977—

This is correct.

The message in thunderbird ends like this:

+Lacf3UgJeeDYX8XwoASn7HTlQBQZViADxPMXppAQXMIBtoezlTgAf6sb762AtbvqoA+eAOR17rn
4muOTrJXGt9BwuaJAnvPeRw91KQG36W17+yiRwMXCdQfbrSkYynEigIKH3koRuURbkDzqHaCoAH5
a1EnmrTut7OVZWsWkDKWom6jcnnWclQEY3

This is wrong, I looked it up in the message outlook downloaded and it is in the middle of the third image.

Reproducible: Always

Steps to Reproduce:
1. Download any messages containing attachments on this server.

Actual Results:  
Get an incomplete message.

Expected Results:  
Get the original message.

I used outlook express 6.00.2900.2180 for comparison, and it downloads the message correctly, so if there is a server bug, it knows how to get around it.

I found the same problem on linux using thunderbird 1.5.0.7 build for fedora core 5 x86_64.
DUP of Bug 92111? See also Bug 390795.
Anyway, get IMAP protocol log.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 92111
You need to log in before you can comment on or make changes to this bug.