Closed Bug 355822 Opened 15 years ago Closed 13 years ago

User profile selection window cropped

Categories

(Toolkit :: Startup and Profile System, defect)

defect
Not set
trivial

Tracking

()

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: ajh, Assigned: dev-null)

References

Details

(Keywords: verified1.9.1)

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.8.1) Gecko/20061003 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.8.1) Gecko/20061003 Firefox/2.0

The Choose User Profile window is not tall enough, cropping the Start Firefox and Quit buttons.

Reproducible: Always

Steps to Reproduce:
Start Firefox with -ProfileManager

Actual Results:  
See attached image (to follow)


Regression in 2.0RC2, not present in 2.0RC1.
Less pronounced in en-US; the buttons are very close to the bottom edge of the window, but not cropped.
Not present in ja-JP-mac or en-US on PPC Mac OS X Mach-O.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 2.0 Branch
The problem is still present in 2.0.0.4.
- Delete <User>\Application Data\Mozilla\Firefox
- Start Firefox with -ProfileManager
Dialog box is correct size, empty user list extends to bottom of Rename Profile... button.
- Create Profile...
User list expands, extending beyond bottom of Delete Profile... button, but dialog size remains the same, with "Start Firefox" and "Exit" buttons pushed almost beyond the end of the panel.
- Exit
- Start Firefox with -ProfileManager
"Start Firefox" and "Exit" buttons are more visible, but cropped, as originally reported.
Whiteboard: CLOSEME 07/14
Attached image screen shot
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007090301 Minefield/3.0a8pre ID:2007090301

same with Minefield.
maybe this is a problem with OS(Japanese)?
similar one, Bug 248648
maybe this will be fixed by the same way as bug 396635 .
Duplicate of this bug: 408333
This problem is still reproduced on
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008061503
Minefield/3.1a1pre
With Windows XP (Japanese) , with Luna, normal Font.
Proposed patch, but not tested because I don't have build environment on Windows.

Can someone test this patch?
This problem can be reproduced also on Linux if small font is used (e.g. change the size of Application font to 6, but this value depends on the font, display resolution setting and so on).

And I've confirmed the Patch v1.0 fixes the problem on Linux.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Patch v1.0 looks fine on WindowsXP SP3
Product: Firefox → Toolkit
Attachment #325525 - Flags: review?(gavin.sharp)
Comment on attachment 325525 [details] [diff] [review]
Patch v1.0
[Checkin: Comment 13]

When profile manager starts, following action is taken:

1. The size of listitem is computed.
   But the size of icon is not considerd because the icon is not yet loaded at this time.
2. The size of listbox is computed based on the size of listitem.
3. The size of window is determined to fit to the contents including the listbox.
4. The icon is loded.
5. The size of listitem is recomputed using the size of icon.
6. The size of listbox is recomputed based on the new size of listitem.

If 6. is bigger than 2., the button falls down to be cropped.

If the size of icon is available at 1, recomputing of size does not happen and the button is not cropped.
To do so, the size of icon can be specified with CSS.
OS: Windows XP → All
Hardware: PC → All
Version: 1.8 Branch → Trunk
Attachment #325525 - Flags: review?(gavin.sharp) → review+
Assignee: nobody → dev-null
Keywords: checkin-needed
Attachment #325525 - Attachment description: Patch v1.0 → Patch v1.0 [Checkin: Comment 13]
Status: NEW → RESOLVED
Closed: 13 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
Blocks: 456757
No longer blocks: 456757
Attachment #325525 - Flags: approval1.9.1?
Comment on attachment 325525 [details] [diff] [review]
Patch v1.0
[Checkin: Comment 13]

Requesting approval for 1.9.1.
The risk is low, because this affects only profile manager, and just specifies icon size.
And it have been baked on mozilla-central for 5 days but no issue is found.
Comment on attachment 325525 [details] [diff] [review]
Patch v1.0
[Checkin: Comment 13]

a191=beltzner
Attachment #325525 - Flags: approval1.9.1? → approval1.9.1+
Keywords: checkin-needed
Whiteboard: checkin-needed for 1.9.1
Verified fix on Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.1b3pre) Gecko/20090115 Shiretoko/3.1b3pre.   Will check this on trunk when b3 builds are out.
You need to log in before you can comment on or make changes to this bug.