Closed Bug 355865 Opened 13 years ago Closed 12 years ago

Since recently full screen mode has spurious tool bars.

Categories

(Firefox :: General, defect)

1.5.0.x Branch
x86
Windows XP
defect
Not set

Tracking

()

VERIFIED INVALID

People

(Reporter: rt66, Unassigned)

References

()

Details

(Whiteboard: CLOSEME 05/07/2008)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

since a recent update (Summer 2006?) there is still a parasitic menu/tool bar appearing even after hitting F11 to obtain full screen. (normal browsing, no tabs, javascript working) 


Thanks to examine this issue.

Reproducible: Always

Steps to Reproduce:
1)Check the example link http://www.shedrupling.org/nav/nav.php?index=deb-eee
2)hit F11 to see the page as it was designed for. In place of full screen I still have a tool bar.
3)Use the navigation bar at the bottom, if you can reach it, as the unwanted toolbar can shift it out of reach.

Alternative:
1)Check the example link http://www.shedrupling.org/nav/nav.php?index=deb-eee
2)click the link "read the stories in full screen" (it is present for IE users!)
3)hit F11, this time it works, I have the full screen. This is because this link is a 
onClick="window.open('URL','NavBonheurFullscreen','fullscreen=yes, scrollbars=no')">. But this uselessly opens a second window.

Actual Results:  
Using normally F11 still produce a half-full screen, with a menu bar (not auto-hide).
To have a true full screen requires a special window.open link with fullscreen=yes and then clicking F11 


Expected Results:  
Full screen should appear automatically and without need for special tricks, just when the user hits F11 (eventually F11 could trigger a series of various modes more or less full screen)


Please note that in the instance a true full screen is strongly needed, and even "critical", for obvious artistic reasons, and that this page does not trap the user, lefting the choice open.

I think full screen should work easily, not trapping the visitor, but without hassle for the newbie user, just respecting his choice. F11 was a simple thing to do. 

Also note that I have now no full screen at all with IE. If you want to catch my visitors...

I have no special info about my configuration.
*** Bug 355864 has been marked as a duplicate of this bug. ***
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 1.5.0.x Branch
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5.

The given URL is a custom 404 page now, but in general, F11 results in a mostly-full screen view, with the toolbar sliding away about 1 second later, leaving a completely full-screen view.

Reporter, do you still see this problem with the latest Firefox 3 beta?
Whiteboard: CLOSEME 07/14 → CLOSEME 05/07/2008
Aaron, I did the tests with Firefox 3.

1) in the case of a standard page, doing F11 shows all the toolbars and system recessing, lefting only a small (some pixels hight) band on the very top of the screen, and also scroll bars if the page is larger than the screen.
-this top band is a bug
-the animations of toolbars recessing are a bit too spectacular, I think. This is not a bug, but it is aestetically disputable. At least they should recess all together. 
-scrollbars are questionable too, see notes bellow

2) when a page opens with the standard javascript onClick="window.open... ...'toolbar=0,scrollbars=0,scrollbars=0,fullscreen=yes') it should display a full screen page.
(for the purpose of this discussion, I placed one such link at the very bottom left of this page: http://www.planet-eolis.net/index.php)
-what I get is a page with some tool bars removed. It is not full screen, I consider this not correct (see notes bellow).
-I have to do F11 to obtain a full screen page, with the same results as with the case 1)


Notes about usefulness of full screen:
-the full screen can be wished by some users, in some cases.
-the site designer can propose the full screen for some reasons (mostry aesthetic or immersion, sometimes simulations)
-i is reallya pity that a useful or beautiful function is more and more threatened.
-the only way for the site designer to propose full screen or taylorised windows is still the use on window.open.
-the aestetical use of full screen make very disturbing the presence of the remaining small band.



Notes on the "safety" issue on full screen
-firefox choose to remove the ability of opening a new window in full screen, to avoid some abuses (site trapping the ignorant user in a full screen page), but this should not come at the expense of legitimate uses of the full screen. It would be much better to keep to the standard, and allow the full screen, while warning the user: «This page is displayed in full screen. Hit F11 to come back to a standard page with navigation bars. Check this box not to see this warning again».



Note on the presence of scrollbars in full screen mode:
-giving the most common aestetical use of full screen, remaining bands, toolbars or scrollbars can be very disturbing.
-after the standard of window.open, scrollbars should NOT be displayed, even when the content is larger than the screen. At least not when we have the parametre scrollbars=0. 
-It would be useful however in other cases to be able to navigate, for instance on an image which would be much larger than the full screen. But in this case (when the site designer allowed for scroolbars with scrollbars=1), because of the aestetical issue, it would be much better to navigate with pulling the page (or image) with the mouse, as we do in Google Earth.   

bug 116503, which you commented on and which was resolved as WONTFIX, covers why you can't use javascript to open a full-screen window.  This bug is probably not the place to re-hash that discussion =)

bug 348880 covers what you called the "small band" at the top of the screen in full-screen mode.  As I pointed out in a comment on that bug, that band is there by design and is not a bug.  Bug 422867 covers a bug relating to the small band at the top, however.

bug 423014 covers one complaint about the "aesthetically disputable" toolbar animation.

Given the above, would you agree that this bug should be resolved as WORKSFORME, since the original complaint was that spurious toolbars were left in full-screen mode?
I don't think this bug is solved, so I shall not mark it workforme (work for me?) and all the more not workforeverybody.

At a pinch, it would make sense to mark it as duplicate, since all its components are adressed separately by other bugs. But there is no mean provided to mark it as duplicate of several bugs.

As to re-hash a discussion here, anyway it is useless, if Mozilla don't heed at the legitimate complains of content creators. If you just want to be a new Microsoft, please enjoy doing so, but when I shall find Firefox bugs which hamper the normal viewing of my sites (which are standard compliants) I shall place a warning for the visitor, as what Firefox is unable to display the page properly. (I already did this, but I since found a better presentation which no more arose the issue.) We DO NOT WANT a browser war. We DO NOT WANT a second Microsoft. We DO NOT WANT browsers which think in our place. We just want standard compliant browsers which display what is written in the code.
If this ticket is not about your original complaint of spurious toolbars in full screen mode, then this will be resolved as INVALID.  The practical impact of this is low, as there are bugs for all the issues you mentioned later.  Please only file one issue per bug in the future.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
CQFD
You need to log in before you can comment on or make changes to this bug.