Moxxi theme is listed as an extension

RESOLVED INVALID

Status

RESOLVED INVALID
12 years ago
3 years ago

People

(Reporter: cameron, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
From what I can tell, the developer probably uploaded it as a "new extension" instead of a theme.

It shows up under the Extensions list in the devCP, and it's hosted in http://releases.mozilla.org/pub/mozilla.org/extensions/moxxi/ but it is definitely a .jar file and appears to have a valid install.rdf etc.

Problem: when you try to install it, it asks you to download the file instead of install it.

So.. I think that since the URI is stored in the version table (the /extensions/ bit is hardcoded) we can just:

UPDATE `main` SET `Type` = 'T' WHERE `ID` =3114 LIMIT 1 ;

and everything should be happy. The next time the developer uploads an update, it'll go to /themes/

Of course I only suspect that the problem is occurring because it was uploaded incorrectly (apparently chameleon/data/db/mozilla-update.sql is no longer updated) someone probably needs to verify that this is the cause first.

Fligtar: Can you confirm that this will not occur in Remora (ie. additem errors if you try to upload an incorrect add-on type?)
(In reply to comment #0)
> UPDATE `main` SET `Type` = 'T' WHERE `ID` =3114 LIMIT 1 ;

ID 3114 is MercadoLibre Peru Buscador extension.

> Fligtar: Can you confirm that this will not occur in Remora (ie. additem errors
> if you try to upload an incorrect add-on type?)

Yes.
(Reporter)

Comment 2

12 years ago
er, 

UPDATE `main` SET `Type` = 'T' WHERE `ID` =3490 LIMIT 1 ;

whoops :D
This theme/extension no longer exists.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Component: Add-ons → Administration
QA Contact: add-ons → administration
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.