The page skip to top when i scroll and click on the page

RESOLVED DUPLICATE of bug 351491

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 351491
12 years ago
12 years ago

People

(Reporter: Martin Pelant, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.1) Gecko/20061003 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.1) Gecko/20061003 Firefox/2.0

Sometimes, when i go to page, scroll down and want to click to link, the page skip to the top as if there was an "href=#top" and <a name=top> was on the top of page.
Then I must scroll down and click second time to the link to go to page.
Its bug in ff 2.0 RC1 and RC2

Reproducible: Sometimes

Steps to Reproduce:
example page
1.go to http://www.albi.cz/
2.click in left menu "Kreslená (14)" it is under "Den Matek"
3.wait, after the page is loaded, scroll to the end of page and click sumewhere in the middle frame

Actual Results:  
the page skip to the begin


No Themes, No extensions
Probably caused by caret browsing in combination with some extension.
If you don't use caret browsing, turn it off. Tools > Options > Advanced > Accessibility > Always use the cursor keys to navigate within pages (or press F7).

Comment 2

12 years ago
I confirm this behaviour for final release of Firefox 2.0 (Linux version).

Problem is really caused when "caret browsing" enabled in browser's setup. No matters if some extensions are installed.

This unwanted behaviour is reproducible only sometimes (about 10-20% of mouse clicks after previous scrolling). This is quite annoying, especially for new Firefox users.

On my opinion this "caret browsing" feature should move to current caret position only when cursor keys are being pressed, not when mouse click events occur.

Comment 3

12 years ago
See https://bugzilla.mozilla.org/show_bug.cgi?id=354619
This is the same bug.

*** This bug has been marked as a duplicate of 351491 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.