Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Import from Sunbird <= 0.3a1 causes data loss

RESOLVED WORKSFORME

Status

Calendar
Import and Export
--
critical
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Sascha Nemecek, Unassigned)

Tracking

({dataloss})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Opera/9.02 (Windows NT 5.1; U; en)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061006 Sunbird/0.3

When importing data from an .ics file created with Sunbird 0.3a1 or older an error message is shown. Additionally VTODOs get lost. 

Reproducible: Always

Steps to Reproduce:
1. Take an .ics file from 0.3a1 or older that contains VTODOs
2. Import the .ics file in the current sunbird version
Actual Results:  
1. An error message is displayed reporting that the import for x items failed
2. VTODOs get lost during the import unreportedly

Expected Results:  
1. The correct number of failed imports (VEVENTs and VTODOs) should be displayed. 
2. The error message should be more user friendly. 
3. It would be a great help if the line numbers of the faild import would be displayed. It's quite annoying to have to make a diff on huge .ics files.
Can you attach an ICS file that when importing shows this error?

Thanks

Updated

11 years ago
Flags: blocking0.3?

Comment 2

11 years ago
Please attach the (anonymized) calendar file that causes this problem to this bug or provide steps how to create such a event/task in Sunbird 0.3a1.

Comment 3

11 years ago
Sascha,
isn't this the same problem as in Bug 356004 you reported?
(Reporter)

Comment 4

11 years ago
Created attachment 241927 [details]
Example calendar file with failing items

The problem when importing the included VEVENT seems to be fixed with the proposed patch in Bug 349715.
(Reporter)

Comment 5

11 years ago
Hi, 

I suppose you are right (same error code). Maybe I was misleaded to think that those are different errors, because of the unequal appearance of the error message. Another difference (at least to the user) is that this error occured on import and the one reported in Bug 356004 while opening an .ics file. 

I'd also like to mention again, that the wrong number of failed items on import was reported. Seems to me, that only failed VEVENTS were reported. VTODOS were dropped silently. 

I also tested the proposed patch from Bug 349715. 
* The good news: no more error messages. 
* The bad news: some data (see VTODOS in attached .ics) are still lost silently. 

I have attached a calendar file now. 


Regards, 
Sascha 

Updated

11 years ago
Keywords: dataloss

Comment 6

11 years ago
(In reply to comment #5)
Adding dependency to Bug 349715.
Depends on: 349715
Flags: blocking0.3?

Comment 7

11 years ago
I use 0.4a1, import some data. Well, it report some pointer wrong, but the data import rightly.

Comment 8

11 years ago
WFM with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070106 Calendar/0.4a1

agree, imported properly and no errors
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.