Crashes [@ nsFormFillController::OnTextEntered]

VERIFIED FIXED

Status

()

Toolkit
Form Manager
--
critical
VERIFIED FIXED
12 years ago
8 years ago

People

(Reporter: smaug, Assigned: smaug)

Tracking

(4 keywords)

Trunk
crash, regression, topcrash, verified1.8.1.4
Points:
---
Bug Flags:
blocking1.8.1.4 +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

According to TB there are few crashes @  	 nsFormFillController::OnTextEntered.
Possible patch coming.

Updated

12 years ago
Component: Form Manager → Satchel
Product: Firefox → Toolkit
QA Contact: form.manager → satchel
Created attachment 241703 [details] [diff] [review]
possible patch

Bryner, since ::OnTextEntered is mainly you code, could you review.
This should fix the possible crash when ownerDocument is null or when mFocusedInput is null (if that is possible).

Other change is to set the return value to something.
That is based on this comment: 
http://lxr.mozilla.org/seamonkey/source/toolkit/components/autocomplete/public/nsIAutoCompleteInput.idl#149
but it shouldn't actually change the functionality because the return value isn't actually handled: http://lxr.mozilla.org/seamonkey/source/toolkit/components/autocomplete/src/nsAutoCompleteController.cpp#1123
Attachment #241703 - Flags: first-review?(bryner)
Comment on attachment 241703 [details] [diff] [review]
possible patch

Should not be possible for mFocusedInput to be null, but better not to crash.  Similarly, I don't know how a text input could be without an ownerDocument, but bulletproofing is fine.
Attachment #241703 - Flags: first-review?(bryner) → first-review+
ownerDocument is *not* guaranteed to be non-null.
Basically if something keeps a reference to a node, but document is deleted, then ownerDocument is null.
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Is this something worth of the branch?
Apparently yes. There are some crashes also on 1.8.
(Assignee)

Updated

12 years ago
Attachment #241703 - Flags: approval1.8.1.3?
Duplicate of this bug: 371910

Updated

12 years ago
Duplicate of this bug: 372535

Comment 8

12 years ago
Smaug, is there a reason you requested approval for 1.8.1.4 and not 1.8.1.3?
(In reply to comment #8)
> Smaug, is there a reason you requested approval for 1.8.1.4 and not 1.8.1.3?

He did ask for approval1.8.1.3, see bug activity. The flag was renamed to approval1.8.1.4 in preparation for a quicker than usual 1.8.1.3 release.
Duplicate of this bug: 373247

Updated

12 years ago
Flags: blocking1.8.1.4?
This became the run-away top crash in FF2.0.0.2 (more crashes than old stand-by 0x00000000 even), and don't appear on the lists for prior versions (with admitedly small populations remaining on older versions). Was this crash tickled by the password manager changes? Seems unlikely, but I don't think 2.0.0.2 made any other form-related changes.
Severity: normal → critical
Flags: blocking1.8.1.4? → blocking1.8.1.4+
Keywords: crash, topcrash
(Assignee)

Updated

12 years ago
Duplicate of this bug: 374785
Comment on attachment 241703 [details] [diff] [review]
possible patch

approved for 1.8.1.4, a=dveditz for release-drivers
Attachment #241703 - Flags: approval1.8.1.4? → approval1.8.1.4+
(Assignee)

Updated

12 years ago
Keywords: fixed1.8.1.4
Keywords: regression
(In reply to comment #11)
> Was this crash tickled by the password manager changes? Seems unlikely,
> but I don't think 2.0.0.2 made any other form-related changes.

bug 286933 was fixed in 1.8.1.2 and seems more directly relevant

Comment 15

11 years ago
I have those annoying crashs almost every day in forums....  when will it be fixed in firefox2 ?

Andreas, in the next security update, you can test it yourself, see:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2.0.0.4-candidates/rc1/

Updated

11 years ago
Duplicate of this bug: 380367

Comment 18

11 years ago
v.fixed on 1.8 branch and Trunk based on the latest Talkback data.  Let's keep a close eye on topcrash reports for 2.0.0.4 after the release to make sure this is gone with no regressions.
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1.4 → verified1.8.1.4
Component: Satchel → Form Manager

Updated

8 years ago
Crash Signature: [@ nsFormFillController::OnTextEntered]
You need to log in before you can comment on or make changes to this bug.