Extension components not excluded by "chrome" filter

RESOLVED FIXED

Status

Other Applications
Venkman JS Debugger
RESOLVED FIXED
11 years ago
7 years ago

People

(Reporter: James Ross, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [vnk-0.9.88][vnk-0.9.88.1])

Attachments

(4 attachments)

(Reporter)

Description

11 years ago
The Venkman code to exclude "chrome" files is Mozilla 1.2 code. It just excludes anything in the same directory as venkman-service.js. It's time to fix that. :)
(Reporter)

Updated

11 years ago
Whiteboard: [0.9.88]
(Reporter)

Updated

11 years ago
Whiteboard: [0.9.88] → [vnk-0.9.88]
(Reporter)

Updated

10 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 1

10 years ago
Created attachment 277135 [details] [diff] [review]
Make components into a dir list and exclude all

This also fixes the chrome filter to work correctly (toggling after starting). Will attach -w diff for review.
(Reporter)

Comment 2

10 years ago
Created attachment 277137 [details] [diff] [review]
diff -w version of previous attachment
Attachment #277137 - Flags: review?(shaver)
(Reporter)

Updated

10 years ago
Assignee: silver → rginda
Status: ASSIGNED → NEW
QA Contact: caillon → venkman

Comment 3

10 years ago
Comment on attachment 277137 [details] [diff] [review]
diff -w version of previous attachment

r=me, but:

* I'd prefer to hold off on checking this in if we can find a timely solution to bug 358286.
* The back of my mind is wondering whether it makes any sense at all to cache the "is this file chrome or a component" info somewhere - given the component dir thing is O(n*m) (for n JS/HTML/XUL files and m component dirs)
Attachment #277137 - Flags: review?(shaver) → review+

Updated

10 years ago
Duplicate of this bug: 424438

Comment 5

7 years ago
Created attachment 466115 [details] [diff] [review]
Updated version of patch

James, the file: stuff is fixed in current HG Vnk now. I attempted to un-bitrot your patch, but I ran into some issues with rec.show() (in venkman-views:

Internal error processing hook “scripts:chrome-filter”.
TypeError: rec.show is not a function @ <chrome://venkman/content/venkman-views.js> 1079

Any clue what that's about?
Attachment #466115 - Flags: review+

Updated

7 years ago
Attachment #466115 - Flags: review+
(Reporter)

Comment 6

7 years ago
It should be rec.unHide().

Comment 7

7 years ago
(In reply to comment #6)
> It should be rec.unHide().

Great, that works. I've commented out the if ("parentRecord" in rec) check, too, as that meant changing back from not showing to showing them didn't work. I tested that change with expanded scripts, seemed to all be just fine, so committed that. Thanks a lot!

(changeset:   654:b63d7bb88a0f)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 8

7 years ago
Of course, I didn't take into account that Fx 4 would nuke this out of orbit because ComsD and friends have been removed, so these directory service calls throw exceptions instead. Great. Patch in a second.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

7 years ago
Created attachment 467062 [details] [diff] [review]
Fix detection on trunk / Moz 2.0
Attachment #467062 - Flags: review?(mnyromyr)

Comment 10

7 years ago
Comment on attachment 467062 [details] [diff] [review]
Fix detection on trunk / Moz 2.0

r=me with bracing style fixed.
Attachment #467062 - Flags: review?(mnyromyr) → review+

Comment 11

7 years ago
(In reply to comment #10)
> Comment on attachment 467062 [details] [diff] [review]
> Fix detection on trunk / Moz 2.0
> 
> r=me with bracing style fixed.

Checked in with braces fixed, changeset 661:db6bde58e48d
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Whiteboard: [vnk-0.9.88] → [vnk-0.9.88][vnk-0.9.88.1]
You need to log in before you can comment on or make changes to this bug.