Add-ons should be limited in the number of categories allowed

VERIFIED DUPLICATE of bug 337773

Status

addons.mozilla.org Graveyard
Policy
--
enhancement
VERIFIED DUPLICATE of bug 337773
11 years ago
2 years ago

People

(Reporter: Todd Vierling, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

This is a general feature request.  While browsing add-ons from the "Get Bookmark Add-ons" link bundled with Firefox 2, I realized that too many extensions have as many as 5 or more categories associated with them.  Just in the first two pages, I found two obvious abuses (bug 356277 and bug 356278), and as I continued to browse, the problem is clearly pandemic.  It seems that everyone's personal "toolbar" extension somehow fits 10 categories at once, when closer inspection proves otherwise.

In reality, there are *very few* add-ons that fit a large number of categories at once:  CustomizeGoogle, MR Tech Local Install, etc.

Reproducible: Always

Steps to Reproduce:
Browse add-ons, examine how many categories are associated with each.
Actual Results:  
One in every 7-10 or so has 5 or more categories, and obviously doesn't fit all of them.  With that, category browsing is near useless, as every page has completely irrelevant add-ons taking up space.


Expected Results:  
Less category spam, so that browsing add-on categories is actually useful.  I'd suggest as a first step auditing all add-ons with more than 6 or 7 categories associated, as there's a high likelihood that those are category spamming.

Going forward, perhaps add-ons should have a limit on the number of categories selected by the author -- say, 4 or 5 -- unless that limit is lifted by administrative request (where needed, e.g. Googlebar or other truly multipurpose add-ons).

*** This bug has been marked as a duplicate of 337773 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

11 years ago
Danke ... I didn't find that one in my search for some reason.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.