Last Comment Bug 356493 - "svg:textpath" ignores presence of "svg:transform" attribute
: "svg:textpath" ignores presence of "svg:transform" attribute
Status: RESOLVED FIXED
: verified1.8.1.2
Product: Core
Classification: Components
Component: SVG (show other bugs)
: 1.8 Branch
: x86 Linux
: -- normal (vote)
: ---
Assigned To: tor
: Hixie (not reading bugmail)
Mentors:
Depends on: 372232
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-12 17:16 PDT by ssen.dev
Modified: 2007-04-05 09:49 PDT (History)
2 users (show)
bzbarsky: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase as an attachment (559 bytes, image/svg+xml)
2006-10-12 17:37 PDT, tor
no flags Details
branch patch for bug 345488 (13.69 KB, patch)
2006-10-13 11:51 PDT, tor
longsonr: review+
roc: superreview+
dveditz: approval1.8.1.1-
jaymoz: approval1.8.1.2+
Details | Diff | Review

Description ssen.dev 2006-10-12 17:16:19 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1) Gecko/20061003 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1) Gecko/20061003 Firefox/2.0

if a path has a transform-atribute and is used as a textpath the text appears at the same position as if the transform-attribute would have been omitted.

Reproducible: Always

Steps to Reproduce:
1. put the following lines in a file and open it with firefox
-----
<?xml version="1.0" ?>
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:svg="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
<head>
	<title>the same path?</title>
</head>
<body>
	<svg:svg width="600" height="400">
		<!-- background -->
		<svg:rect height="100%" width="100%" fill="grey"/>
		<svg:circle cx="100" cy="100" r="75" fill="lightgrey"/>
		<svg:circle cx="100" cy="100" r="75" transform="scale(2) translate(100)" fill="lightgrey"/>
		<!-- definition of path -->
		<svg:defs>
			<svg:path transform="scale(2) translate(100)" id="path" d="M 100,25  A 75 75 0 1 1 99,25"/>
		</svg:defs>
		<!-- draw the path in red -->
		<svg:use xlink:href="#path" stroke="red" fill="none"/>
		<!-- text along the path dosn't match the drawn path. -> transform is ignored! -->
		<svg:text>
			<svg:textPath xlink:href="#path">-this text should appear around the big circle and not the small-</svg:textPath>
		</svg:text>
	</svg:svg>
</body>
</html>
Comment 1 tor 2006-10-12 17:37:19 PDT
Created attachment 242128 [details]
testcase as an attachment
Comment 2 tor 2006-10-12 17:38:08 PDT
Fixed on trunk in bug 345488.
Comment 3 tor 2006-10-13 11:51:55 PDT
Created attachment 242215 [details] [diff] [review]
branch patch for bug 345488
Comment 4 Robert Longson 2006-10-16 02:43:09 PDT
Comment on attachment 242215 [details] [diff] [review]
branch patch for bug 345488

>Index: layout/svg/base/src/nsSVGDefsFrame.h
...
> protected:
>   nsCOMPtr<nsIDOMSVGMatrix> mCanvasTM;
>+  PRBool mPropagateTransform;

Should be PRPackedBool I suppose although it makes no difference in this case and it's only a branch patch.

r=longsonr whether or not you change it.
Comment 5 tor 2006-10-17 09:01:01 PDT
Comment on attachment 242215 [details] [diff] [review]
branch patch for bug 345488

Sure, I'll do the PRBool -> PRPackedBool change.
Comment 6 tor 2006-10-19 11:19:58 PDT
Comment on attachment 242215 [details] [diff] [review]
branch patch for bug 345488

Specification compliance issue, similar fix has been on the trunk since August 7th.
Comment 7 Daniel Veditz [:dveditz] 2006-11-29 11:17:43 PST
Comment on attachment 242215 [details] [diff] [review]
branch patch for bug 345488

approved for 1.8 branch, a=dveditz for drivers
Comment 8 Daniel Veditz [:dveditz] 2006-11-29 11:20:01 PST
Comment on attachment 242215 [details] [diff] [review]
branch patch for bug 345488

Sorry, I have to rescind approval. We need to move non-blockers into the next release.
Comment 9 Jay Patel [:jay] 2006-12-27 14:52:27 PST
Comment on attachment 242215 [details] [diff] [review]
branch patch for bug 345488

Approved for 1.8 branch, a=jay for drivers.
Comment 10 tor 2007-01-02 13:44:58 PST
Checked in on MOZILLA_1_8_BRANCH.
Comment 11 Jay Patel [:jay] 2007-01-22 17:53:09 PST
v.fixed on the 1.8 branch with Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.2pre) Gecko/20070122 BonEcho/2.0.0.2pre, testcase looks good.
Comment 12 Boris Zbarsky [:bz] 2007-04-05 09:49:17 PDT
This checkin caused bug 372232.

Note You need to log in before you can comment on or make changes to this bug.