If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[vi-VN] Vietnamese: Firefox

RESOLVED FIXED

Status

Mozilla Localizations
Registration & Management
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: Jasper Thái, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

I've translated Firefox 1.5.0.7 to Vietnamese. So I would like register to localize Firefox. I can continue translating with next releases. I'm working with 2.0 RC2 now.

Reproducible: Always



Expected Results:  
Vietnamese versions

Updated

11 years ago
Assignee: nobody → registration
Component: Other → Registration & Management
QA Contact: registration
Version: zu / Zulu → unspecified

Comment 1

11 years ago
Also see Bug 296050 and Bug 282099...maybe the people there should try to work together to get at least one translation attempt finished ;).

Updated

11 years ago
Summary: Transalte Firefox into Vietnamese! → [vi] Translate Firefox into Vietnamese!

Updated

10 years ago
Summary: [vi] Translate Firefox into Vietnamese! → [vi] Vietnamese: Firefox

Updated

10 years ago
Summary: [vi] Vietnamese: Firefox → [vi-VN] Vietnamese: Firefox
On behalf of the Mozilla Project, I'd like to apologise for the delay in processing this request. We very much appreciate offers of help in localization.

If anyone reading this is still interested in helping to translate one or more Mozilla products into the language that this bug is about, please add a new comment to this bug to confirm your interest, saying again which products you would like to localize e.g., Firefox, Thunderbird. We will then make the necessary arrangements.
(Reporter)

Comment 3

10 years ago
I've translated Firefox 2.0.0.6 to Vietnamese, on going with 2.0.0.7
Jasper: that's great! There seem to be no less than four bugs open on translating Firefox into Vietnamese - this one, bug 282099, bug 296050 and bug 328554. So if people respond in one of the other ones, perhaps you can form a team together, or they can do other products.

It would be great to get you and your localisation tied into the Mozilla process. You can find out about it by reading this wiki page:
http://wiki.mozilla.org/L10n:Starting_a_localization

Create yourself a wiki page for your localisation, which registers you as the team for that language. Then, follow the instructions on the wiki to produce a language pack you can distribute through addons.mozilla.org. Once you have reached that stage, we can consider your pack for official status - although I should warn you that this is a separate process with its own complexities. Still, the community will still be able to get your pack from addons.mozilla.org in the meantime.

If you have read carefully and find the documentation isn't good enough in any way, please let us know and we will improve it.

Gerv
(Reporter)

Comment 5

10 years ago
Thanks. It's coming soon.
Jasper: how are you getting on? Have you managed to make any progress?

Gerv
(Reporter)

Comment 7

10 years ago
I've finished for Firefox 2, and submit it as an extension. But the extension still in ``sandbox''!
I don't know when users can download my extension.
(In reply to comment #7)
> I've finished for Firefox 2, and submit it as an extension. But the extension
> still in ``sandbox''!
> I don't know when users can download my extension.
> 


I've moved your extension from the sandbox to the public side of AMO (https://addons.mozilla.org/en-US/firefox/addon/5954).  I noticed it is marked as available for windows only - I'd suggest changing that to being offered on "ALL" platforms so you get the widest possible audience.
(Reporter)

Comment 9

10 years ago
Thank you!
The Linux version will come soon!

Comment 10

9 years ago
Hi Jasper, I saw your comments in bug 432406 and bug 356527.

What we need to proceed is a current state of your firefox 3 sources. Based on a review of those, I can then vouch for your cvs access over in bug 356527. More information on this phase can be found on http://wiki.mozilla.org/L10n:Becoming_an_Official_Localization.

I'd like to propose a change to the locale code, too. We're trying to just use the language part of it where feasible, and for Vietnamese, that seems to be the case, so we'd prefer vi over vi-VN. What do you think?
Blocks: 356527
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 11

9 years ago
That seems reasonable. We don't have any localizations that use the (mostly older) terms prevalent in, say, the United States or Germany.
(Reporter)

Comment 12

9 years ago
Created attachment 330907 [details]
Vi pack, alpha test ~80%

This is the source of my vi langpack.  Though there're lots of things must be accomplished, but I've posted it as a pre-release on the addons page so that local users can help me refine the pack.
I think we should stick to the vi-VN code, which has already been used since FF2.
Thái, I've sent you our an email attaching our complete langpack.
(Reporter)

Comment 14

9 years ago
No no! We should use `vi' than `vi-VN.' Some others projects also use `vi' such as OpenOffice.org, Gnome, KDE, ...
That's ok. Just a small change, so whatever.
Created attachment 346290 [details]
[vi] 3.1 trunk localization

NGUYỄN's team prepared vi 3.1 trunk localization

I'm reviewing it right now
I reviewed the package at listed missing entities: I compared your package (source) to en-US from today.

I also emailed Hung asking the team to work on those and once its done we will ignite a process of preparing vi for initial checkin into our repository and preparation for Fx 3.1 vi release.
Created attachment 346587 [details]
[vi] 3.1 trunk localization

updated to the trunk vi localization.

Ready to check in
Attachment #346290 - Attachment is obsolete: true
I'm really appreciated what you've done so far, Zbigniew!
If nothing goes wrong, please tell me what I should do next.

By the way, while waiting for your reviews, should I translate the in-product pages? However, the steps to translate in-product pages seem not to be as clear as FF localization guide. On [1], the link to the release notes is for 2.0.0.5?! There are still many obsolete pages on the wiki, though.

Now I'm also localizing some addons, and about their AMO descriptions, the authors tell me that they don't see any options to choose vi-VN locale, which means, from what I've read on MDC, I have to file a bug for vi-VN localization on AMO. However, it seems that I have to have CVS access first and should have the AMO po file completed, whereas one or two extensions are going to be released next week, and if I'm not fast enough, then I'll have to wait for their next releases which may take even months. Should I file a bug? (Though I still think Mozilla just simply enable that option for addons authors?)

Comment 20

9 years ago
In case you're not aware of it, the Vietnamese localization of AMO is about 1/3 done at Narro: https://l10n.mozilla.org/narro/narro_project_file_list.php?l=vi&p=12 .
Hi Hung, Minh,

This bug is ready to be closed. The last thing we need to do is include https://wiki.mozilla.org/L10n:Teams:vi in https://wiki.mozilla.org/L10n:Localization_Teams using the {{L10n:Teams:vi}} syntax. However right now, the https://wiki.mozilla.org/L10n:Teams:vi page breaks the layout of L10n:Localization_Teams by using many ==FOO== and ===BAR===. Can you please edit it to match the format of other L10n:Teams pages? (e.g. https://wiki.mozilla.org/L10n:Teams:fr). The additional notes are fine and helpful so please keep them, just don't use the === (level 3) headers.

Thanks!
I've modified the Teams:vi page. It should be fine to include it into the Localization Teams page now.
Thanks :)
Thanks!

Marking as fixed. Congrats to all involved! :)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.