Last Comment Bug 356579 - remove tr-tdk search plugin on update
: remove tr-tdk search plugin on update
Status: RESOLVED FIXED
: fixed1.8.0.8
Product: Firefox
Classification: Client Software
Component: Installer (show other bugs)
: 1.5.0.x Branch
: All All
: -- normal (vote)
: ---
Assigned To: Axel Hecht [:Pike]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-13 08:10 PDT by Axel Hecht [:Pike]
Modified: 2009-06-16 05:37 PDT (History)
2 users (show)
dveditz: blocking1.8.0.8+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
l10n part, don't ship tr-tdk on 1.5.0.x (1.24 KB, patch)
2006-10-13 08:12 PDT, Axel Hecht [:Pike]
l10n: review+
dveditz: approval1.8.0.8+
Details | Diff | Splinter Review
installer part, remove tr-tdk on update (583 bytes, patch)
2006-10-13 08:13 PDT, Axel Hecht [:Pike]
benjamin: review+
dveditz: approval1.8.0.8+
Details | Diff | Splinter Review

Description Axel Hecht [:Pike] 2006-10-13 08:10:04 PDT
As pointed out in bug 354576, the tr-tdk search plugin shipped with turkish versions of 1.5 is broken due to an incompatible site change, and can't be resurrected.

Updates should remove the plugin, and thus, we should add the two files to removed-files.in.

Patch coming up.
Comment 1 Axel Hecht [:Pike] 2006-10-13 08:12:30 PDT
Created attachment 242189 [details] [diff] [review]
l10n part, don't ship tr-tdk on 1.5.0.x
Comment 2 Axel Hecht [:Pike] 2006-10-13 08:13:41 PDT
Created attachment 242191 [details] [diff] [review]
installer part, remove tr-tdk on update

The second patch should get rid of the tr-tdk plugins for existing installs, just like we did with dictionary.com.
Comment 3 Axel Hecht [:Pike] 2006-10-13 10:19:21 PDT
We should take this bug instead of bug 354576, if this get's plussed, minus the other.
Comment 4 Daniel Veditz [:dveditz] 2006-10-13 10:34:18 PDT
This is the 1.8.0 branch version of bug 354576, moving blocking flag here.
Comment 5 Ahmet Serkan Tıratacı 2006-10-15 10:59:46 PDT
(In reply to comment #1)
> Created an attachment (id=242189) [edit]
> l10n part, don't ship tr-tdk on 1.5.0.x
> 

This one is OK: +

I can't set flag + as I'm told by Bugzilla that I'm not authorised.
Comment 6 Axel Hecht [:Pike] 2006-10-15 14:00:21 PDT
Comment on attachment 242189 [details] [diff] [review]
l10n part, don't ship tr-tdk on 1.5.0.x

marking review by aserkant (note, I fixed your bugzilla privs, too).

Requesting approval for 1.8.0.8
Comment 7 Daniel Veditz [:dveditz] 2006-10-15 22:19:23 PDT
Comment on attachment 242189 [details] [diff] [review]
l10n part, don't ship tr-tdk on 1.5.0.x

approved for 1.8.0 branch, a=dveditz
Comment 8 Daniel Veditz [:dveditz] 2006-10-15 22:19:45 PDT
Comment on attachment 242191 [details] [diff] [review]
installer part, remove tr-tdk on update

approved for 1.8.0 branch, a=dveditz
Comment 9 Axel Hecht [:Pike] 2006-10-16 07:54:24 PDT
Checked in.

I'm leaving the bug open for investigating how things should behave on the 1.8 branch wrt updates from the 1.5 tree to the 2.0 one.
Comment 10 Axel Hecht [:Pike] 2009-06-16 05:37:26 PDT
This seems to have been fixed allright by now.

Note You need to log in before you can comment on or make changes to this bug.