Closed Bug 356819 Opened 13 years ago Closed 13 years ago

drag&drop to a background tab that's scrolled off the tabstrip not functional if the drag source is another application

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 3 alpha7

People

(Reporter: dao, Assigned: martijn.martijn)

References

Details

Attachments

(2 files, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061015 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061015 Minefield/3.0a1

from bug 248612 comment 25:
> When the drag source is from another application, then aDragSession.sourceNode
> is probably null. It shouldn't be too hard to fix, but it might be tricky, I'll
> try to fix that in a different patch.

Reproducible: Always
Blocks: 248612
OS: Windows XP → All
Hardware: PC → All
Dragging a link from my text editor to the locationbar hangs Firefox completely, but also the text editor is rather upset with a sudden CPU usage of 50%. Before it dies it complains about a script.
Sounds like another bug, Ria.
Ria, isn't that bug 317770?
Attached patch patch (obsolete) — Splinter Review
This fixes it for me.
This was added with bug 333791, where there was talk about dragsession.sourceNode == null when that should not happening, so I might be breaking here something on the mac, possibly.
Attachment #242982 - Flags: review?(sspitzer)
Attached patch patch, diff -w version (obsolete) — Splinter Review
Attached patch patchSplinter Review
Ugh, I need a better editor.
Attachment #242984 - Flags: review?(sspitzer)
Attachment #242982 - Attachment is obsolete: true
Attachment #242983 - Attachment is obsolete: true
Attachment #242982 - Flags: review?(sspitzer)
(In reply to comment #3)
> Ria, isn't that bug 317770?
>
Yes, it is. 

Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 242984 [details] [diff] [review]
patch

martijn, sorry for letting this sit so long in my queue.

can you get mano or gavin to review this?
Attachment #242984 - Flags: review?(sspitzer)
Re-summarizing, I thought the problem was any non-selected tab before looking at the patch.
Assignee: nobody → martijn.martijn
Summary: drag&drop to a background tab not functional if the drag source is another application → drag&drop to a background tab that's scrolled off the tabstrip not functional if the drag source is another application
Comment on attachment 242984 [details] [diff] [review]
patch

This still seems to apply, r=me.
Attachment #242984 - Flags: review+
Whiteboard: [checkin needed]
Target Milestone: --- → Firefox 3 beta1
Keywords: checkin-needed
Whiteboard: [checkin needed]
Checking in toolkit/content/widgets/tabbrowser.xml;
/cvsroot/mozilla/toolkit/content/widgets/tabbrowser.xml,v  <--  tabbrowser.xml
new revision: 1.232; previous revision: 1.231
done
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: in-testsuite?
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.