Closed Bug 356822 Opened 18 years ago Closed 15 years ago

Add keyboard combination to switch between collapsed and expanded message headers

Categories

(Thunderbird :: Message Reader UI, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 480623

People

(Reporter: hendrik, Unassigned)

Details

It is not possible to switch between collapsed and expanded message headers without using the mouse.  This is a bad point concerning accessability.

I am talking about the little plus in the standard them which is in the message part of the main window, right next to the message subject.  So not the message listing, but the frame in which the message itself is shown.  For more details and a discussion, see Usenet message egnlrm$ahf$1, in alt.fan.mozilla.

There is an extension which almost offers this functionality, Headers Toggle (https://addons.mozilla.org/thunderbird/1489/).  However, it does a three-way toggle: normal, all and collapsed headers.  Switching between normal and all headers is already possible through View -> Headers -> All or Normal, which can be reached over Alt+V, then h, then a or n.  There is no similar switch, or menu item, or shortcut to expand/collapse the message header.
OS=ALL?
valid accessibility issue?
Assignee: mscott → nobody
assuming you can focus on the element (which I believe you can) then you can activate it; so it's not completely inaccessible.  I'm fairly sure this has gone away w/ TB3 since we currently have a  ( show details ) button and with bug 480623 we'll only have the detailed header view.
OS: Linux → All
Hardware: x86 → All
duping to bug 480623. please reopen the bug if you find your issue is not resolved by version 3
Status: NEW → RESOLVED
Closed: 15 years ago
Component: Mail Window Front End → Message Reader UI
QA Contact: front-end → message-reader
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.