Closed Bug 356908 Opened 14 years ago Closed 14 years ago

Old dates (before 01/01/1900) in date boxes ("From" and "To" in "New Event" dialog, "Date" and "Due Date" in "New Task" dialog) change when focus is lost

Categories

(Calendar :: Internal Components, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 238632

People

(Reporter: standsongrace, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

Any time a date before 1900 is entered in a date box, and the focus is lost, the date jumps forward. For instance, if you try to create a new event with the "From" date "25/10/1899", when the date input box loses focus, the contents jump forward to "26/10/1899". Similarly for the "To" box, and the "Date" and "Due Date" boxes when creating a new task. Dates between 1/1/1800 and 31/12/1899 jump forward by one day, dates between 1/1/1700 and 31/12/1799 jump forward by two days, and dates before 1/1/1700 jump forward by three days.

Reproducible: Always



Expected Results:  
Dates don't change randomly.
Confirmed per Bug 354073 Comment #8
Status: UNCONFIRMED → NEW
Ever confirmed: true
Likely related to bug 328632, bug 350.  Problem is that Javascript Date incorrectly calculates whether century 00 years are leap years, but formatter correctly calculates, so the day becomes offset when parsed and reformatted when it loses focus.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 238632
You need to log in before you can comment on or make changes to this bug.