Search autocomplete/suggestions use only half of the available width due to the word "suggestions"

RESOLVED FIXED in Firefox 3 alpha3

Status

()

Firefox
Search
RESOLVED FIXED
11 years ago
4 years ago

People

(Reporter: Jesse Ruderman, Assigned: Neil Deakin (not available until Aug 9))

Tracking

Trunk
Firefox 3 alpha3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Steps to reproduce:
1. Focus the search bar.
2. Type "pas".

Result: The autocomplete results and suggestions are cut off at about 12 characters, using only about half the width available.  It seems that they are constrained because of the presence of the word "Suggestions" to the right of the first suggestion.

Expected: only cut off the suggestion that's immediately to the left of the word "Suggestions", or give the word "Suggestions" its own (non-selectable) row.
(Reporter)

Comment 1

11 years ago
Created attachment 242750 [details]
screenshot
This probably depends on the solution to bug 339363 (see bug 339363 comment 1).
Depends on: 339363
(Reporter)

Comment 3

11 years ago
This problem exists on Windows too.
OS: Mac OS X 10.4 → All
Hardware: Macintosh → All
(Reporter)

Comment 4

11 years ago
*** Bug 363274 has been marked as a duplicate of this bug. ***
Created attachment 256845 [details] [diff] [review]
allow cells to overflow
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #256845 - Flags: superreview?(neil)
Attachment #256845 - Flags: review?(neil)

Comment 6

11 years ago
Comment on attachment 256845 [details] [diff] [review]
allow cells to overflow

Sorry, but this patch makes no sense to me whatsoever.
Attachment #256845 - Flags: superreview?(neil)
Attachment #256845 - Flags: review?(neil)

Comment 7

11 years ago
Comment on attachment 256845 [details] [diff] [review]
allow cells to overflow

>-    nscoord width = aTextRect.width;
>+    width = maxWidth;
OK, I get this now. r+sr=me; can't verify the toolkit change though.
Attachment #256845 - Flags: superreview+
Attachment #256845 - Flags: review+
Comment on attachment 256845 [details] [diff] [review]
allow cells to overflow

OK, maybe gavin can check the toolkit part
Attachment #256845 - Flags: review?(gavin.sharp)
Attachment #256845 - Flags: review?(gavin.sharp) → review+
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
Target Milestone: --- → Firefox 3 alpha3
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.