In most cases, "Suggestions" text in search suggestions drop-down is truncated

RESOLVED WONTFIX

Status

()

Firefox
Search
--
minor
RESOLVED WONTFIX
12 years ago
5 years ago

People

(Reporter: Joe Hughes, Unassigned)

Tracking

(Depends on: 1 bug)

unspecified
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix?])

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
This is happening because the "comment" column isn't wide enough at most typical window widths.  Rather than widening the column, though, the real solution is probably a more in-depth rewrite of the way search suggestions are displayed along the lines of Beltzner's sketches at: https://bugzilla.mozilla.org/attachment.cgi?id=223064
(Reporter)

Updated

12 years ago
Flags: blocking-firefox2?
Also, using the column truncates longer suggestions in a weird way.
Flags: blocking-firefox2? → blocking-firefox2+

Updated

12 years ago
Target Milestone: --- → Firefox 2 beta1

Comment 2

12 years ago
Joe, can you look at what Myk recently checked in for Microsummaries? He was facing a similar issue and created a read-only menuitem that looks a lot like Beltzner's upper-left design - that, with the "Suggestions ..." text seems like the right way to go.

Updated

12 years ago
Target Milestone: Firefox 2 beta1 → Firefox 2 beta2
Whiteboard: [at risk]

Comment 3

12 years ago
Joe - have you had a chance to look at this?
(Reporter)

Comment 4

12 years ago
I've looked at the way Myk's doing it in microsummaries, and he's using a menu rather than the tree view that the autocomplete system uses.  So it's not straightforward to do the same thing here; we'd basically need to either replace the tree view with a different type of widget, or improve the capabilities of the tree view to allow this behavior.
I suppose to get some room back we could just replace the start of any search term that the user has typed in with an elipses:

 ( [G] foo                    O.v)
  --------------------------------
  | football                     |
  |------------------ suggestions|
  | ..d for thought              |
  | ..tball statistics           |
  | ..tball records...           |

I wish there were a clearer path here.
Uh, that comment probably belongs on another bug. But which one?
Not going to hold on this, there isn't a clear fix, and its not that serious.
Flags: blocking-firefox2+ → blocking-firefox2-
Whiteboard: [at risk]

Comment 8

12 years ago
*** Bug 351945 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
The shortening of the searchbar in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060914 BonEcho/2.0 has made trying to see search history autocomplete entries virtually impossible.

Comment 10

12 years ago
This bug is the reason I think?
https://bugzilla.mozilla.org/show_bug.cgi?id=348779

(In reply to comment #9)
> The shortening of the searchbar in Mozilla/5.0 (Windows; U; Windows NT 5.1;
> en-US; rv:1.8.1) Gecko/20060914 BonEcho/2.0 has made trying to see search
> history autocomplete entries virtually impossible.
> 

Comment 11

12 years ago
(In reply to comment #10)
> (In reply to comment #9)
> > The shortening of the searchbar in Mozilla/5.0 (Windows; U; Windows NT 5.1;
> > en-US; rv:1.8.1) Gecko/20060914 BonEcho/2.0 has made trying to see search
> > history autocomplete entries virtually impossible.
>
> This bug is the reason I think?
> https://bugzilla.mozilla.org/show_bug.cgi?id=348779

There's no good path here.

We can set a high min width on the search and address bars, and they'll stay "usable", but can't be made small.

We can try and preserve space in one at the expense of the other, but that just means that one gets very unusable fast, and we don't know which one the user cared about.

Or we can just let both shrink equally, and trust that if the user really doesn't like that, they'll either move flexy boxes onto separate rows, or else make their window bigger.

The old behavior was close to the second of these and the new behavior is closer to the third.  That seems better to me.

Comment 12

12 years ago
Created attachment 243333 [details]
A screenshot showing the problem

I've attached a screenshot showing a more irritating form of this. 
The white space should auto-expand as the % of truncated results nears 100, but if that's too difficult then can it at least be used more completely?

Comment 13

12 years ago
While you're at it, could I also suggest that make the suggestion entries more distinct, so as not to be confused with the search history? One time someone was using my computer and typed in "hot i" and the list suggested "hot indian girls" and the guy was like, "wow I didn't know you were into Indian chicks" And I had to explain that the search bar looks for related words on the Internet dynamically.
*** Bug 360867 has been marked as a duplicate of this bug. ***

Comment 15

12 years ago
I recommend raising the priority of this bug, since it renders the current feature mostly unusable.

Comment 16

12 years ago
(In reply to comment #11)
> Or we can just let both shrink equally, and trust that if the user really
> doesn't like that, they'll either move flexy boxes onto separate rows, or else
> make their window bigger.

The suggestions box shouldn't be dependent on the size of the search box.  Since it's a transient popup it should size to accommodate the width of the search suggestions.  See my attachment with a mock-up.

Comment 17

12 years ago
Created attachment 253556 [details]
Mockup of how the search suggestions should appear.
Assignee: mozilla → nobody
Target Milestone: Firefox 2 beta2 → ---
Version: 2.0 Branch → unspecified

Updated

11 years ago
Duplicate of this bug: 397350

Comment 19

9 years ago
Created attachment 361107 [details]
screenshot (Firefox trunk)

Much better than when this bug was first filed, but could still be improved.

How about leaving off the common prefix, or making the dropdown wider as needed?

Updated

8 years ago
Depends on: 579716
This is still the case for the url bar though not for t he seach bar. 
For the url bar, the dropdown still appears to be limited to the current width of the url bar.   For the search bar, the dropdown can be wider than the search bar.
Whiteboard: [wontfix?]
Yes, this is true. Our dropdowns popup will match the width of the associated field. So in the case of the merged location bar and search bar, the width of the location bar can still be narrow enough as to truncate some of the search suggestions.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.