Autocomplete in Address bar ignores bookmarks

RESOLVED DUPLICATE of bug 278747

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 278747
12 years ago
12 years ago

People

(Reporter: Ben Jamieson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Autocomplete in the location bar still fails to include bookmarked URLs.


Reproducible: Always

Steps to Reproduce:
1. Make sure you have at least one bookmark
2. Start typing the url of the bookmarked site
3. Watch as autocomplete fails miserably.

Actual Results:  
There are no results. It doesn't work.

Expected Results:  
Autocomplete will locate bookmarked sites as well as those in browser history.


Bookmarks, by their nature, are URLs the browser user wishes to revisit. This is why they added the URL as a bookmark.

Failing to include these in the sutocomplete routine is stupidly user-unfriendly and hampers overall usability of the software.

To revisit a bookmarked URL I must manually search through menus, folders and possibly nested folders revisit the URL

The 'feature' is standard on all other Mac browsers and its absense in Firefox will alienate Mac users new to the browser.
See https://addons.mozilla.org/firefox/404/ or https://addons.mozilla.org/firefox/2300/

*** This bug has been marked as a duplicate of 278747 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.