Closed Bug 278747 Opened 17 years ago Closed 13 years ago

Include bookmarks url's and titles in auto-complete url feature

Categories

(Firefox :: Address Bar, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 3 beta3

People

(Reporter: age.bosma, Assigned: dietrich)

References

(Depends on 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

In addition to the recent history url's, it would be very handy to have the
auto-complete url feature to auto-complete url's from the bookmarks as well.
Bookmarks are known url's to Mozilla/Firefox so why not use them?
I haven't seem this feature in any browser yet and imo it would be a very good
one to extent Mozilla's/Firefox's usability.

Reproducible: Always

Steps to Reproduce:
see Seamonkey bug 155320
->New
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: firefox → bugs
Component: General → Location Bar and Autocomplete
QA Contact: general → davidpjames
Flags: blocking-aviary1.1?
RFEs like this one don't block releases.
Flags: blocking-aviary1.1?
Duplicate of Core bug 101642?
Assignee: bugs → nobody
Depends on: 155320
QA Contact: davidpjames → location.bar
Version: unspecified → Trunk
*** Bug 275014 has been marked as a duplicate of this bug. ***
No longer depends on: 155320
*** Bug 296864 has been marked as a duplicate of this bug. ***
*** Bug 305339 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 249468 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
That bug is about bookmark keywords, not all bookmarks, a subtle distinction.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
*** Bug 314166 has been marked as a duplicate of this bug. ***
*** Bug 332440 has been marked as a duplicate of this bug. ***
*** Bug 357753 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 371440
With the move to Places, this is now the default behavior, so can this bug be marked FIXED?
this is not fixed yet.

this, and bug #393570, should be coming in m11
Assignee: nobody → sspitzer
Status: REOPENED → NEW
Summary: Include bookmarks url's in auto-complete url feature → Include bookmarks url's and titles in auto-complete url feature
Target Milestone: --- → Firefox 3 M11
Flags: blocking-firefox3?
Isn't this sort of a dupe of bug 393570? Or is it just that this bug will be fixed by that one?
Its not really a dupe, but its close to the same thing.
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P3
Priority: P3 → P1
> Its not really a dupe, but its close to the same thing.

mconnor is right, here's the difference:

for this bug, when attempting to autocomplete, the fix in bug #394038 now makes it so we search history title and url (in moz_places) and also the bookmark title.

for bug #393570, I think we will need to make sure that unvisited bookmarks are not hidden in order to autocomplete against them.
Status: NEW → ASSIGNED
Depends on: 394038
already part of the fix for bug #393570
Assignee: sspitzer → dietrich
Status: ASSIGNED → NEW
How should the bookmark title be shown? The patch that fixes bug 393570 will just show the bookmark title.

Should it also show the destination page's title as well if it's available? Something like..

Cool site -- Mozilla Home Page

where -- is a long dash — that separates the bookmark title from the place title.
My opinion is the bookmark title should override the page title.

The page title is the default bookmark title when you type Ctrl-D, and if the user makes an additional effort to edit it, they know best. So I'm happy that the patch behaves like it does.
> My opinion is the bookmark title should override the page title.

this was beltzner and faaborg's opinion as well, see bug #411452

the fix for this has landed as part of bug #394038, but I'll leave it to dietrich to mark it fixed.

(perhaps he is keeping it open to ensure we have tests written for it?)
Duplicate of this bug: 405645
fixed by bug 394038
Status: NEW → RESOLVED
Closed: 16 years ago13 years ago
Flags: in-litmus?
Resolution: --- → FIXED
dietrich, could we clone and modify your test_000_frecency.js (or test_history_autocomplete_tags.js) to test this?

somewhere we in bugzilla beltzner/faaborg wrote that we should be preferring bookmark title to page title, if the bookmark title matches.

it seems like we should be able to write a unit test for both:

a)  autocomplete should find unvisited bookmark titles
b)  autocomplete should prefer bookmark title of page title.

additionally, we could have unit tests for:

c)  autocomplete should not find unvisited livemark items
d)  autocomplete should find visited livemark items

(sorry for lobbing work at you from the sidelines!)
Flags: in-testsuite?
Verified fix on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3.  
Status: RESOLVED → VERIFIED
Duplicate of this bug: 314166
this is in litmus in a few different test case scenarios.
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.