Occasionally ok button does not enable on File Open/Save dialog focus

RESOLVED FIXED

Status

()

Firefox
File Handling
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: nemo, Unassigned)

Tracking

2.0 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Tested on linux and windows.
On windows (reproduced by several people).  File dialog did not have focus by default.  Clicking on dialog quite frequently did not enable the ok button.

On linux (gnome 2.16), file dialog had focus by default with ok enabled.  Periodically however the ok button would not be enabled on dialog appearance.

In both cases, unfocusing and refocusing or minimising and unminimising browser usually corrected, but was rather confusing to the user who thought Firefox was not allowing them to download the file.

Was unable to reproduce in 1.5.0.7 under linux.

Updated

11 years ago
Version: Trunk → 2.0 Branch
(Reporter)

Updated

11 years ago
Summary: Occasionally open button does not enable on File Open/Save focus → Occasionally ok button does not enable on File Open/Save dialog focus
This probably explains bug 353407 and bug 357132.
Blocks: 353407, 357132

Comment 2

11 years ago
Happened to me lots of times on Firefox 1.5.x (WinXP SP2). Still haven't downloaded any file on 2.0 so can't tell there. Happens absolutely always if I click to download many files, for example, by opening many download links in tabs. After I click OK on one file, "Save in" window opens, and I can see in the background the other download dialog with disabled OK.

Sometimes when I choose the save location, the other download dialogs disappear, unfocusing and refocusing *Firefox window* makes them appear again.
(Reporter)

Comment 3

11 years ago
Re: comment #2 - you said in background a disabled OK button.
Apparently desired behaviour is for the *unfocused* dialog to have a disabled Ok.
In this case a *focused* dialog has a disabled Ok - are you able to reproduce that in 1.5?

Comment 4

11 years ago
this should be marked as duplicate of
https://bugzilla.mozilla.org/show_bug.cgi?id=353407
and changed this and
https://bugzilla.mozilla.org/show_bug.cgi?id=357132
to depend on that, not reverse.

Updated

11 years ago
Blocks: 361909

Comment 5

10 years ago
Was this fixed by the patch for bug 361909? (You'll need to test a recent Firefox 3 build to tell.)

Comment 6

10 years ago
This seems to be fixed (bug 361909). Please comment with steps to reproduce in Firefox 3 if you still see the problem.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.