Ok button on file open with/save to disk dialog is disabled

RESOLVED DUPLICATE of bug 361909

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 361909
13 years ago
12 years ago

People

(Reporter: dietrich, Assigned: sdwilsh)

Tracking

2.0 Branch
Firefox 3 alpha7
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20060918 BonEcho/2.0

Sometimes, when downloading PDF files, the OK button is disabled. Clicking it will re-enable it, then a 2nd click performs the proper action.

This PDF works fine:

http://dietrich.ganx4.com/mozilla/test.pdf

However, the PDFs on clearbenefits.com, the MoCo benefits provider, have the bug (screenshot coming). The site is http://myclearbenefits.com, but is password protected. I'll try to find an example that is not protected.
(In reply to comment #0)
> Clicking it
> will re-enable it, then a 2nd click performs the proper action.

Revision: Clicking the disabled button sometimes will perform the proper action as if it was not disabled. I've seen it both ways now.
More notes:

- tested w/ clean profile, bug still occurs
- tested w/ js turned off, bug still occurs
- sometimes the ok button works the first time, but if i hit cancel and download again, then the bug will occur
The first 2 PDFs on this page exhibit the problem:

http://www.portlandonline.com/fire/index.cfm?c=26414
I am encountering this problem with Release Candidate 2 as well.  I can't figure out how to duplicate it, though.  Sometimes a PDF loads properly once, but then if I try to reopen another PDF somewhere else, it exhibits this bug.  The only way to view PDFs is to save them to my desktop, unless I restart Firefox.  I use Mac OS X.4.8, on a MacBook.  
Build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/2006100316 Firefox/2.0
Feel free to email me back if you'd like me to try anything to try and fix this.  The pull-down menu for Hardware says "PC," I think it should be changed to Macintosh.  
I think this ought to be fixed before the release of Firefox 2.0, because it's a really annoying bug.
so this bug made it into final FF2.

it's not OSX specific (at least win xp is affected too) and it's not specific to PDF files.

so far i experienced this buggy behaviour on .zip, .doc, .xls and a couple more filetypes (look like any filetypes not handled by FF directly or via plugin?!?)

but the bug seems to be fixed in 3.0a1
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061204 GranParadiso/3.0a1
test on the sample url from comment #4

any chance we can get a backport and have this fixed in 2.0.x ?
OS: Mac OS X 10.4 → All
Summary: Ok button on file download dialog is disabled for some PDFs → Ok button on file open with/save to disk dialog is disabled
FWIW, I saw this same bug in 1.0.x at my brother-in-law's house over the holidays :)
I'm also seeing this in FF2 on XP ... and I'm seeing it more on other people's installations too.

I've found the easiest way to get it enabled is to, change focus to another application and then back to Firefox. (e.g. alt-tab away, then alt-tab back).

Once Firefox has the focus, the OK button gets enabled (not instantaneously, but within less than 1 second).
One more comment.  I also can reproduce the problem at the site specified in comment #4.   

I've found another way to enable to OK button.   Just take the focus away from the  save dialog (like by clicking the web page in the background, and then refocusing on the save dialog.
Here using firefox 2.0.0.1 and happens. If you click in the main firefox window and then click the save dialog (without closing it) the save button is enabled.
Flags: blocking-firefox3?
Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
and happen always with link of comment #4.
Happen for many types of files, not only PDF, on many web sites.

Workaround always working:
1st method: click on OK reenable the OK button, click again to save/open.
2nd method: click everywhere outside the dialog box, then reclick on the dialog box reenable the OK button, click OK to save/open.
As far as I can tell the disabling of the ok button was introduced by Bug 260560.  
Here still present using 2.0.0.3
Is this a duplicate of bug 264492?
(In reply to comment #15)
> Is this a duplicate of bug 264492?

Some of the reports might be, but I think this bug is more about a fault with the button-disabling code, rather than the actual MIME type handling (that bug).
Flags: blocking-firefox3? → blocking-firefox3+
Duplicate of this bug: 357132
Target Milestone: --- → Firefox 3 alpha6
Duplicate of this bug: 316108
Assignee: nobody → sdwilsh
Duplicate of this bug: 317787
Duplicate of this bug: 334318
Duplicate of this bug: 354671
Duplicate of this bug: 355968
Duplicate of this bug: 356779
Duplicate of this bug: 365720
Duplicate of this bug: 365708
Target Milestone: Firefox 3 alpha6 → Firefox 3 beta1
I'm fairly sure that this is a regression from Bug 260560 as Comment 13 suggests.  It's that or a duplicate of Bug 264492 (or maybe even both).

Based on the code, I really think this may be related to Bug 264492 - but Comment 12 make me think it is in fact the code from Bug 260560.  I can't reproduce this behavior with the page in Comment 4 with |Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a6pre) Gecko/20070626 Minefield/3.0a6pre|

What might solve this is removing these lines from onFocus:
if (aEvent.target != this.mDialog.document)
  return;

My guess is that maybe some element inside of the dialog is getting the focus, so it fails this check.  However, this is really hard to test this theory as I only see this behavior randomly.
Duplicate of this bug: 386126
I don't think the severity should be major. After all, there is an "easy workaround" most of the time: multiple clicks on the OK button. I would say at least to change the severity to normal.
I think this is a major bug.  I'm a "power user" and  it confused me for a while, and the work-around is annoying.

For less sophisticated users this is a major usability issue.  Many will not understand why they are not allowed to save.  I've had to explain to a number of people how to work around this issue ... it reflects badly on Firefox.   It's also the only bug in firefox that has any impact on my day-to-day use.

I'm not sure why sdwilsh can't reproduce the problem by loading PDFs in comment 4.  It's reproducible to me on multiple machines.
This is probably a dupe of Bug 361909
removing myself from CC
Yes, this is the way I've repro'd bug 361909.


Because the other bug has a patch, this is being marked as a dupe.  Thanks lilmatt!
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: flock8499
You need to log in before you can comment on or make changes to this bug.