Migration fails to fire on launch if the previous system default browser is Opera

RESOLVED FIXED

Status

()

Firefox
Migration
--
major
RESOLVED FIXED
11 years ago
5 years ago

People

(Reporter: tracy, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +
blocking1.8.1.1 -
blocking1.8.0.9 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Seen on 2.0 and 1.5.0.8 candidate builds.

steps to reproduce:
-remove/rename Firefox profile folder
-Run Seamonkey or Opera and set it as the default browser
-Launch Firefox

Tested results:
Firefox launches bypassing the Migration Wizard

expected results:
The Migration Wizard appears then Firefox launches when the wizard is dismissed

note: If IE or Firefox was previously set as the default browser, then the Migration wizard appears as expected.

I have a feeling this has been around a while. juanb filed a similar bug back in August, but then invalidated it when he couldn't immediately reproduce.  (Firefox was then probably the default on his retries) I'll start my search for the regression window around then
(Reporter)

Comment 1

11 years ago
nominating for the next set of point releases.
Flags: blocking1.8.1.1?
Flags: blocking1.8.0.9?
(Reporter)

Comment 2

11 years ago
removing regression keyword. 

I tested back to 1.5 release; it is affected by this bug.  I checked another theory as to why I hadn't seen this before.  Basically I've never set Opera as my default, so wouldn't have caught it from there. Until just recently I had been using Mozilla 1.7.13 as my default browser.  Mozilla builds also don't cause this bug.  So it's just Seamonkey and Opera.

So why does Firefox fail to launch migration after either of those browsers was set as default?
Keywords: regression
Summary: Migration fails to fire on Launch if the previous system default browser isn't IE or Firefox (Opera, Seamonkey) → Migration fails to fire on Launch if the previous system default browser isn't IE or Firefox or Mozilla (Opera, Seamonkey)
Not blocking 1.8.1.1 if IE works, but would like this looked at.

mconnor: is there a good assignee for this one?
Flags: wanted1.8.1.x+
Flags: blocking1.8.1.1?
Flags: blocking1.8.1.1-
Flags: blocking1.8.0.9?
Flags: blocking1.8.0.9-
Assignee: nobody → gavin.sharp
Severity: critical → major
Status: NEW → ASSIGNED
Priority: -- → P1
Flags: wanted1.8.1.x+
So I looked into this a little bit, and found several bugs:
1) On the trunk, profile migration is busted in all cases due to the patch for bug 345517. I filed bug 364042 for this.
2) Opera's installer puts bogus data into the registry, which makes our registry reading code barf (it inserts an extra byte after the null-terminated string, which makes the check at http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/xpcom/ds/nsWindowsRegKey.cpp&rev=1.6#439 fail). I've reported this bug to Opera, I don't know whether we want to work around it or not. I think I'll morph this bug to cover that issue.
3) SeaMonkey (as of Seamonkey 1.0) now uses an internal name of "SeaMonkey" rather than "apprunner", so we fail to detect those versions as valid default browsers. That means that the profile migration doesn't show up when SeaMonkey is the default browser. I filed bug 364041 for that.

Even after I fix bug 364041 locally, SeaMonkey isn't listed as an option in the dialog. That's probably a separate bug that I'll look into once bug 364041 is fixed.
Priority: P1 → P2
Summary: Migration fails to fire on Launch if the previous system default browser isn't IE or Firefox or Mozilla (Opera, Seamonkey) → Migration fails to fire on launch if the previous system default browser is Opera
Target Milestone: --- → Firefox 3
Version: unspecified → Trunk
(Reporter)

Comment 5

10 years ago
This remains broken in Fx3b2 and latest Minefield nightly builds.  However, it appears to be a larger problem. I can set default to IE7, Fx2.0.0.11, Opera or even Mozilla1.8, but when I try migration on fresh install of the trunk based builds I get no migration dialog.

I can get migration to fire from 2.0.0.11 if I clean up everything (including reg keys)

I'm concerned my system is horked though.
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
Target Milestone: Firefox 3 → Firefox 3 beta4
Tracy, if there's any profile data at all we won't prompt to migrate on first run.  You need to nuke all of %appdata%/Mozilla/Firefox to get this to run, by design.

The specific issue with Opera here doesn't block, its not a regression and its very late in the cycle to muck with the migration code.
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
Priority: P2 → P4
I reported the bug to Opera a while ago, but I don't think they have any way to followup. Need to test to see whether this is still an issue, I guess.
Assignee: gavin.sharp → nobody
Status: ASSIGNED → NEW
Priority: P4 → --
Target Milestone: Firefox 3 beta4 → ---
Depends on: 715099

Updated

5 years ago
Depends on: 707601
No Opera migrator available now, and the other issue discussed here is fixed by the migrators-fallback-list in ProfileMigraotr.js (to be moved to MigrationUtils.jsm soon).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
No longer depends on: 707601
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.