Closed Bug 357975 Opened 18 years ago Closed 18 years ago

Lightning does not query CalDAV server if the first login did not return any caldav items to the REPORT command

Categories

(Calendar :: Provider: CalDAV, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 360076

People

(Reporter: jakub, Unassigned)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Lightning 0.3

If the CalDAV server currently has not calendar items and you start lightning. It logs in to the server properly but does not display the Today, Tomorrow items in the left bottom area. It also stops querying the server when changing the month/day views. You can add (PUT) items - that works fine. But in the next day/month view change they disappear because the caldav server is not queried at all.

If the CalDAV server has some items and lightning is started it all works properly. It seems that Lightning marks a flag the server is unreachable or something... Not sure.

This issue has been verified with 2 different CalDAV server sw including Bedework.

Reproducible: Always

Steps to Reproduce:
1. Delete all caldav items on the server
2. Start lightning
3. Add new calendar item
4. Change view there and back - see it disappeared

Actual Results:  
No items displayed although there are some

*** This bug has been marked as a duplicate of 360076 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.